Bug 1538704 - ugene needs to be rebuild against Qt 5.9.4
Summary: ugene needs to be rebuild against Qt 5.9.4
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: ugene
Version: 27
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Yuliya Algaer
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: qt594_f27
TreeView+ depends on / blocked
 
Reported: 2018-01-25 15:40 UTC by Rex Dieter
Modified: 2018-01-29 13:11 UTC (History)
1 user (show)

(edit)
Clone Of:
(edit)
Last Closed: 2018-01-29 13:11:23 UTC


Attachments (Terms of Use)

Description Rex Dieter 2018-01-25 15:40:44 UTC
KDE SIG is working on bringing a Qt 5.9.4 update to f27.  ugene will need to be rebuilt against it (f27-kde koji target is being used for this).

I see in f27/ branch, ugene has been updated to 1.29.0, but not built yet.

ugene-1.28.1-1.fc27 is currently in updates-testing

I would like your input on how best to proceed.  The simplest thing to do would be to simply use what's in f27 branch already, and build 1.29.0 .  I've kicked off a scratch build:
https://koji.fedoraproject.org/koji/taskinfo?taskID=24439741
(to make sure it builds and works first... to verify that's a viable option).

What do you think?

Comment 1 Rex Dieter 2018-01-25 18:14:20 UTC
To clarify current situation with details:

ugene-1.28.1-1.fc27 has been in updates-testing for about 2 months,
https://bodhi.fedoraproject.org/updates/FEDORA-2017-6771419c24

current f27/ branch with .spec at 1.29.0 is broken with missing sources.


My own tentative recommended plan is:
* push existing update stable relatively soon (definitely before Qt 5.9.4 has any chance of going stable)

* revert f27 branch back to 1.28.1 and do a simple rebuild


I think this is the simplest way forward.  I will implement it soon (probably this coming Mon, Jan 29) if there are no comments or objections before then.

Comment 2 Rex Dieter 2018-01-29 12:16:24 UTC
Moving forward with the Monday plan.

Comment 3 Rex Dieter 2018-01-29 13:11:23 UTC
Adding ugene-1.28.1-2.fc27 to
https://bodhi.fedoraproject.org/updates/FEDORA-2018-3c21305b93


Note You need to log in before you can comment on or make changes to this bug.