Bug 1538779 - No validation of volume name on gluster volume heal subcommand
Summary: No validation of volume name on gluster volume heal subcommand
Keywords:
Status: CLOSED DUPLICATE of bug 1333705
Alias: None
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: cli
Version: rhgs-3.2
Hardware: All
OS: Linux
unspecified
low
Target Milestone: ---
: ---
Assignee: Ravishankar N
QA Contact: Rahul Hinduja
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-01-25 19:49 UTC by Patrick Ladd
Modified: 2018-01-30 03:45 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-01-30 03:45:09 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Patrick Ladd 2018-01-25 19:49:04 UTC
Description of problem:
Using an invalid volume name is not flagged as an error

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Run "gluster volume heal foo"

Actual results:

# gluster volume heal foo
Launching heal operation to perform index self heal on volume foo has been unsuccessful on bricks that are down. Please check if all brick processes are running.


Expected results:
# gluster volume heal foo
Volume foo does not exist


Additional info:

Comment 2 Ravishankar N 2018-01-30 03:45:09 UTC
This is fixed in rhgs-3.4.0 via BZ 1333705. Hence marking it as a duplicate.

*** This bug has been marked as a duplicate of bug 1333705 ***


Note You need to log in before you can comment on or make changes to this bug.