Bug 1538807 - [3.7] Installer terminates after single node reports error despite error tolerance
Summary: [3.7] Installer terminates after single node reports error despite error tole...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Cluster Version Operator
Version: 3.7.0
Hardware: Unspecified
OS: Unspecified
high
low
Target Milestone: ---
: 3.7.z
Assignee: Russell Teague
QA Contact: Weihua Meng
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-01-25 21:38 UTC by Russell Teague
Modified: 2018-04-05 09:36 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Incorrect batch size calculations in Ansible 2.4.1 would cause playbooks to fail when using max_fail_percentage. The batch calculations were updated in Ansible 2.4.2 to correctly account for failures in each batch.
Clone Of: 1504075
Environment:
Last Closed: 2018-04-05 09:36:18 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2018:0636 None None None 2018-04-05 09:36:45 UTC

Comment 2 Weihua Meng 2018-01-26 01:29:07 UTC
ansible 2.4.2 is expected in OCP 3.7 repo, according to "use latest ansible in OpenShift puddle now until we are notified that we will no longer ship ansible in OpenShift anymore."

Comment 3 Scott Dodson 2018-01-26 20:01:40 UTC
(In reply to Weihua Meng from comment #2)
> ansible 2.4.2 is expected in OCP 3.7 repo, according to "use latest ansible
> in OpenShift puddle now until we are notified that we will no longer ship
> ansible in OpenShift anymore."

We haven't shipped ansible 2.4 in any OCP repos prior to OCP 3.9. It's been shipped via RHEL Extras which just shipped 2.4.2.0 yesterday.

Comment 4 Weihua Meng 2018-01-28 05:59:42 UTC
Fixed as ansible 2.4.2 is in rhel-7-server-extras-rpms

and right ansible version should be used according to openshift official doc

https://docs.openshift.com/container-platform/3.7/install_config/upgrading/automated_upgrades.html

If you are upgrading from OpenShift Container Platform 3.6 to 3.7, manually disable the 3.6 channel and enable the 3.7 channel on each master and node host:

# subscription-manager repos --disable="rhel-7-server-ose-3.6-rpms" \
    --enable="rhel-7-server-ose-3.7-rpms" \
    --enable="rhel-7-server-extras-rpms" \
    --enable="rhel-7-fast-datapath-rpms"
# yum clean all

Comment 8 errata-xmlrpc 2018-04-05 09:36:18 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:0636


Note You need to log in before you can comment on or make changes to this bug.