Bug 1538935 - [downstream clone - 4.1.9] Failed to upgrade to rhvh-4.1-0.20180125.0
Summary: [downstream clone - 4.1.9] Failed to upgrade to rhvh-4.1-0.20180125.0
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-node (Show other bugs)
(Show other bugs)
Version: unspecified
Hardware: Unspecified Unspecified
urgent
urgent
Target Milestone: ovirt-4.1.10
: ---
Assignee: Yuval Turgeman
QA Contact: Huijuan Zhao
URL:
Whiteboard:
Keywords: Regression, TestBlocker, ZStream
Depends On: 1538925
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-01-26 07:58 UTC by rhev-integ
Modified: 2018-04-16 11:14 UTC (History)
16 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
undefined
Story Points: ---
Clone Of: 1538925
Environment:
Last Closed: 2018-04-16 11:14:42 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Node
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2018:1128 None None None 2018-04-16 11:14 UTC
oVirt gerrit 86808 master MERGED osupdater: fixed TypeError on MountPoint 2018-01-26 08:07 UTC

Description rhev-integ 2018-01-26 07:58:53 UTC
+++ This bug is an upstream to downstream clone. The original bug is: +++
+++   bug 1538925 +++
======================================================================

Created attachment 1386485 [details]
All logs from host (/tmp/imgbased.log, /var/log/*, sosreport)

Description of problem:
Upgrade failed when upgrade to rhvh-4.1-0.20180125.0
There is failed info during upgrade, and missing new build boot entry.

Version-Release number of selected component (if applicable):
From:
redhat-virtualization-host-4.1-20171101.0
To:
redhat-virtualization-host-4.1-20180125.0


How reproducible:
100%
regression bug

Steps to Reproduce:
1. Clean install redhat-virtualization-host-4.1-20171101.0
2. Reboot and login RHVH4.1, setup local repos, upgrade via:
   # yum update
3. Focus on the upgrade process
4. Reboot, focus on the boot entries

Actual results:
1. After step3, upgrade failed, there is failed info during upgrade:
# yum update
......
--> Running transaction check
---> Package redhat-virtualization-host-image-update.noarch 0:4.1-20180125.0.el7_4 will be obsoleting
---> Package redhat-virtualization-host-image-update-placeholder.noarch 0:4.1-7.0.el7 will be obsoleted
--> Finished Dependency Resolution

Dependencies Resolved

==================================================================================================================================================
 Package                                           Arch             Version                        Repository                                Size
==================================================================================================================================================
Installing:
 redhat-virtualization-host-image-update           noarch           4.1-20180125.0.el7_4           rhel-7-server-rhvh-4-beta-rpms           615 M
     replacing  redhat-virtualization-host-image-update-placeholder.noarch 4.1-7.0.el7

Transaction Summary
==================================================================================================================================================
Install  1 Package

Total download size: 615 M
Is this ok [y/d/N]: y
Downloading packages:
redhat-virtualization-host-image-update-latest.rpm                                                                         | 615 MB  00:00:08    
Running transaction check
Running transaction test
Transaction test succeeded
Running transaction
  Installing : redhat-virtualization-host-image-update-4.1-20180125.0.el7_4.noarch                                                            1/2
warning: %post(redhat-virtualization-host-image-update-4.1-20180125.0.el7_4.noarch) scriptlet failed, exit status 1
Non-fatal POSTIN scriptlet failure in rpm package redhat-virtualization-host-image-update-4.1-20180125.0.el7_4.noarch
  Erasing    : redhat-virtualization-host-image-update-placeholder-4.1-7.0.el7.noarch                                                         2/2
  Verifying  : redhat-virtualization-host-image-update-4.1-20180125.0.el7_4.noarch                                                            1/2
  Verifying  : redhat-virtualization-host-image-update-placeholder-4.1-7.0.el7.noarch                                                         2/2

Installed:
  redhat-virtualization-host-image-update.noarch 0:4.1-20180125.0.el7_4                                                                          

Replaced:
  redhat-virtualization-host-image-update-placeholder.noarch 0:4.1-7.0.el7                                                                        

Complete!

2. After step4, missing new build boot entry


Expected results:
1. After step3, should upgrade successful, there should be no failed/error info during upgrade.
2. After step4, there should be new build boot entry.

Additional info:
1. No such issue in the last build, so this is regression issue.
2. Some errors info in /tmp/imgbased.log:
Traceback (most recent call last):
  File "/usr/lib64/python2.7/runpy.py", line 162, in _run_module_as_main
    "__main__", fname, loader, pkg_name)
  File "/usr/lib64/python2.7/runpy.py", line 72, in _run_code
    exec code in run_globals
  File "/tmp/tmp.J55PpYHxLB/usr/lib/python2.7/site-packages/imgbased/__main__.py", line 53, in <module>
    CliApplication()
  File "/tmp/tmp.J55PpYHxLB/usr/lib/python2.7/site-packages/imgbased/__init__.py", line 82, in CliApplication
    app.hooks.emit("post-arg-parse", args)
  File "/tmp/tmp.J55PpYHxLB/usr/lib/python2.7/site-packages/imgbased/hooks.py", line 120, in emit
    cb(self.context, *args)
  File "/tmp/tmp.J55PpYHxLB/usr/lib/python2.7/site-packages/imgbased/plugins/update.py", line 56, in post_argparse
    base_lv, _ = LiveimgExtractor(app.imgbase).extract(args.FILENAME)
  File "/tmp/tmp.J55PpYHxLB/usr/lib/python2.7/site-packages/imgbased/plugins/update.py", line 118, in extract
    "%s" % size, nvr)
  File "/tmp/tmp.J55PpYHxLB/usr/lib/python2.7/site-packages/imgbased/plugins/update.py", line 99, in add_base_with_tree
    new_layer_lv = self.imgbase.add_layer(new_base)
  File "/tmp/tmp.J55PpYHxLB/usr/lib/python2.7/site-packages/imgbased/imgbase.py", line 191, in add_layer
    self.hooks.emit("new-layer-added", prev_lv, new_lv)
  File "/tmp/tmp.J55PpYHxLB/usr/lib/python2.7/site-packages/imgbased/hooks.py", line 120, in emit
    cb(self.context, *args)
  File "/tmp/tmp.J55PpYHxLB/usr/lib/python2.7/site-packages/imgbased/plugins/osupdater.py", line 123, in on_new_layer
    raise ConfigMigrationError()
imgbased.plugins.osupdater.ConfigMigrationError

(Originally by Huijuan Zhao)

Comment 1 Huijuan Zhao 2018-01-29 07:49:07 UTC
This bug is fixed in rhvh-4.1-0.20180126.0, QE will verify this bug when the status is ON_QA.


Test version:
From:
redhat-virtualization-host-4.1-20171101.0
To:
redhat-virtualization-host-4.1-20180126.0


Test steps:
Same as comment 0

Comment 2 Huijuan Zhao 2018-01-29 07:54:52 UTC
Change the status to VERIFIED according to Comment 1

Comment 6 errata-xmlrpc 2018-04-16 11:14:42 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:1128


Note You need to log in before you can comment on or make changes to this bug.