Bug 1538989 - etcd should be updated to the specifed etcd_version during upgrade
Summary: etcd should be updated to the specifed etcd_version during upgrade
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Cluster Version Operator
Version: 3.9.0
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: 3.10.0
Assignee: Vadim Rutkovsky
QA Contact: liujia
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-01-26 10:30 UTC by liujia
Modified: 2018-07-30 19:09 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-07-30 19:09:00 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2018:1816 None None None 2018-07-30 19:09:34 UTC

Description liujia 2018-01-26 10:30:59 UTC
Description of problem:
Run upgrade against ocp (3.1.9 etcd) with specified etcd_version, but the exact version did not take effect.

TASK [etcd : Install etcd for etcdctl] *****************************************
task path: /usr/share/ansible/openshift-ansible/roles/etcd/tasks/auxiliary/drop_etcdctl.yml:2
ok: [x.x.x.x] => {"attempts": 1, "changed": false, "msg": "", "rc": 0, "results": ["Loaded plugins: product-id, search-disabled-repos, subscription-manager\nThis system is not registered with an entitlement server. You can use subscription-manager to register.\nPackage matching etcd-3.1.9-2.el7.x86_64 already installed. Checking for update.\nNothing to do\n"]}
....
....
TASK [etcd : Update etcd RPM to etcd-3.2*] *************************************
task path: /usr/share/ansible/openshift-ansible/roles/etcd/tasks/upgrade/upgrade_rpm.yml:17
changed: [x.x.x.x] => {"attempts": 1, "changed": true, "msg": "", "rc": 0, "results": ["Loaded plugins: product-id, search-disabled-repos, subscription-manager\nThis system is not registered with an entitlement server. You can use subscription-manager to register.\nResolving Dependencies\n--> Running transaction check\n---> Package etcd.x86_64 0:3.1.9-2.el7 will be updated\n---> Package etcd.x86_64 0:3.2.9-3.el7 will be an update\n--> Finished Dependency Resolution\n\nDependencies Resolved\n\n================================================================================\n Package   Arch        Version           Repository                        Size\n================================================================================\nUpdating:\n etcd      x86_64      3.2.9-3.el7       oso-rhui-rhel-server-extras      8.8 M\n\nTransaction Summary\n================================================================================\nUpgrade  1 Package\n\nTotal download size: 8.8 M\nDownloading packages:\nDelta RPMs disabled because /usr/bin/applydeltarpm not installed.\nRunning transaction check\nRunning transaction test\nTransaction test succeeded\nRunning transaction\n  Updating   : etcd-3.2.9-3.el7.x86_64                                      1/2 \nwarning: /etc/etcd/etcd.conf created as /etc/etcd/etcd.conf.rpmnew\n  Cleanup    : etcd-3.1.9-2.el7.x86_64                                      2/2 \n  Verifying  : etcd-3.2.9-3.el7.x86_64                                      1/2 \n  Verifying  : etcd-3.1.9-2.el7.x86_64                                      2/2 \n\nUpdated:\n  etcd.x86_64 0:3.2.9-3.el7                                                     \n\nComplete!\n"]}

Version-Release number of the following components:
ansible-2.4.2.0-2.el7.noarch
openshift-ansible-3.9.0-0.24.0.git.0.735690f.el7.noarch

How reproducible:
always

Steps to Reproduce:
1. Rpm install ocp v3.7 with etcd 3.1.9
2. Run upgrade with specified etcd_version in inventory file
etcd_version=3.1.9
3.

Actual results:
Etcd was upgraded to 3.2.9

Expected results:
Etcd should be updated to the same version with etcd_version.

Additional info:
Refer to line154 in
https://github.com/openshift/openshift-ansible/blob/master/inventory/hosts.example

Comment 2 Scott Dodson 2018-04-16 17:37:00 UTC
We're not going to fix this, we're going to simply remove the reference from example inventory.

Comment 3 Vadim Rutkovsky 2018-04-17 09:24:22 UTC
Created https://github.com/openshift/openshift-ansible/pull/7992

Comment 4 Vadim Rutkovsky 2018-04-20 08:38:01 UTC
Fix is available in openshift-ansible-3.10.0-0.25.0

Comment 5 liujia 2018-04-23 09:06:13 UTC
Verified on openshift-ansible-3.10.0-0.27.0.git.0.abed3b7.el7.noarch

"etcd_version" was not supported yet. Both doc and code. 

Upgrade cases.

Comment 7 errata-xmlrpc 2018-07-30 19:09:00 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:1816


Note You need to log in before you can comment on or make changes to this bug.