Bug 1539063 - Cannot restore backup of system disk when using multipath+software raid
Summary: Cannot restore backup of system disk when using multipath+software raid
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: rear   
(Show other bugs)
Version: 7.4
Hardware: Unspecified
OS: Linux
medium
medium
Target Milestone: rc
: ---
Assignee: Pavel Cahyna
QA Contact: David Jež
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-01-26 14:51 UTC by Renaud Métrich
Modified: 2018-10-30 11:44 UTC (History)
3 users (show)

Fixed In Version: rear-2.4-1.el7
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2018-10-30 11:43:19 UTC
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Github rear rear issues 1722 None None None 2018-05-28 09:22 UTC
Github rear rear pull 1819 None None None 2018-05-28 09:37 UTC
Red Hat Product Errata RHBA-2018:3293 None None None 2018-10-30 11:44 UTC
Red Hat Knowledge Base (Solution) 3341091 None None None 2018-02-01 12:46 UTC

Description Renaud Métrich 2018-01-26 14:51:13 UTC
Description of problem:

Trying to restore a backup of a system booting with multipath + software raid, at the rescue prompt, after starting multipathd or executing "rear recover", the multipath devices are not found.
This is due to mdadm building the array at boot, preventing multipath from grabbing the disks later.


Version-Release number of selected component (if applicable):

rear-2.00


How reproducible:

Always


Steps to Reproduce:
1. Setup a VM with 4 SCSI disks (2 images only to have multipath)

2. Install the system with rootvg on RAID1 on the 2 multipath disks

3. Create a rescue image ("rear mkrescue")

4. Boot the rescue image

5. Run "multipathd" and "multipath -l"


Actual results:

No multipath device listed


Additional info:

The workaround is to delete the md device:

mdadm --stop /dev/mdX

Comment 2 Renaud Métrich 2018-02-01 12:46:32 UTC
The proposed workaround is not sufficient, because as soon as the disk is touched (e.g. via parted), the MD array will be rebuilt.

The fix (on RHEL at least) is to disable the automatic array creationg udev rule /lib/udev/rules.d/65-md-incremental.rules by creating an empty file /etc/udev/rules.d/65-md-incremental.rules

This can be done by appending "touch etc/udev/rules.d/65-md-incremental.rules" to /usr/share/rear/build/GNU/Linux/110_touch_empty_files.sh:

# cat /usr/share/rear/build/GNU/Linux/110_touch_empty_files.sh
...
	touch etc/udev/rules.d/65-md-incremental.rules
popd >&8

Comment 3 Renaud Métrich 2018-05-28 09:36:47 UTC
Pull Request: https://github.com/rear/rear/pull/1819

Comment 4 Pavel Cahyna 2018-06-27 16:24:22 UTC
1539063 merged upstream in 2.4/89dbd45e1ad37f49421c7154813f972cb2b63a0e

Comment 9 errata-xmlrpc 2018-10-30 11:43:19 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:3293


Note You need to log in before you can comment on or make changes to this bug.