Bug 1539094 - [3.7] Setting multiple values for OPTIONS with containerized installation fails to start node
Summary: [3.7] Setting multiple values for OPTIONS with containerized installation fai...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Installer
Version: 3.7.0
Hardware: Unspecified
OS: Unspecified
medium
high
Target Milestone: ---
: 3.7.z
Assignee: Fabian von Feilitzsch
QA Contact: Johnny Liu
URL:
Whiteboard:
Depends On: 1510358
Blocks: 1539091
TreeView+ depends on / blocked
 
Reported: 2018-01-26 15:58 UTC by Fabian von Feilitzsch
Modified: 2018-04-05 09:36 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
The OPTIONS value in /etc/sysconfig/atomic-openshift-node now works properly when multiple options are specified with containerized installations.
Clone Of: 1510358
Environment:
Last Closed: 2018-04-05 09:36:18 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2018:0636 None None None 2018-04-05 09:36:45 UTC

Comment 3 Johnny Liu 2018-01-29 07:05:50 UTC
Verified this bug with openshift v3.7.27, still reproduced.

# journalctl -f  -u atomic-openshift-node.service 
<--snip-->
Jan 29 02:03:03 ip-172-18-2-97.ec2.internal systemd[1]: Starting atomic-openshift-node.service...
Jan 29 02:03:04 ip-172-18-2-97.ec2.internal atomic-openshift-node[60575]: Error response from daemon: No such container: atomic-openshift-node
Jan 29 02:03:08 ip-172-18-2-97.ec2.internal atomic-openshift-node[60585]: Error: invalid argument "3 --disable=proxy" for --loglevel=3 --disable=proxy: strconv.ParseInt: parsing "3 --disable=proxy": invalid syntax



# cat /etc/sysconfig/atomic-openshift-node
OPTIONS=--loglevel=3 --disable=proxy
CONFIG_FILE=/etc/origin/node/node-config.yaml
IMAGE_VERSION=v3.7.27


# docker images
REPOSITORY                                                  TAG                 IMAGE ID            CREATED             SIZE
registry.reg-aws.openshift.com:443/openshift3/node          v3.7.27             9afbe5c76fe2        29 hours ago        1.303 GB

Comment 4 Scott Dodson 2018-02-09 13:37:33 UTC
In v3.7.29-1

Comment 5 Johnny Liu 2018-02-13 05:06:38 UTC
Verified this bug with openshift-ansible-3.7.29-1.git.0.e1bfc35.el7.noarch, and PASS.


Setting openshift_node_env_vars={"OPTIONS": "--loglevel=3 --disable=proxy"} in inventory host file, trigger a docker containerized install. The setting is written into /etc/sysconfig/atomic-openshift-node.

# cat /etc/sysconfig/atomic-openshift-node
OPTIONS=--loglevel=3 --disable=proxy
CONFIG_FILE=/etc/origin/node/node-config.yaml
IMAGE_VERSION=v3.7.29


node service is running well.

BTW, once set the above option to node config file, pod would fail to be deployed.
# oc get po
NAME              READY     STATUS    RESTARTS   AGE
router-1-deploy   0/1       Error     0          29m

# oc logs router-1-deploy
error: couldn't get deployment router-1: Get https://172.31.0.1:443/api/v1/namespaces/default/replicationcontrollers/router-1: dial tcp 172.31.0.1:443: getsockopt: no route to host

Comment 9 errata-xmlrpc 2018-04-05 09:36:18 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:0636


Note You need to log in before you can comment on or make changes to this bug.