Bug 1539166 - [bitrot] scrub ondemand reports it's start as success without additional detail
Summary: [bitrot] scrub ondemand reports it's start as success without additional detail
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: bitrot
Version: mainline
Hardware: Unspecified
OS: Unspecified
low
low
Target Milestone: ---
Assignee: Sunny Kumar
QA Contact:
bugs@gluster.org
URL:
Whiteboard:
Depends On: 1517463
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-01-26 19:46 UTC by Sunny Kumar
Modified: 2018-06-20 17:58 UTC (History)
8 users (show)

Fixed In Version: glusterfs-v4.1.0
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1517463
Environment:
Last Closed: 2018-06-20 17:58:10 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Sunny Kumar 2018-01-26 19:46:35 UTC
+++ This bug was initially created as a clone of Bug #1517463 +++

Description of problem
======================

When you start ondemand scrub process, gluster cli tool reports sheer
"volume bitrot: success". This output could be improved to point out
that the scrub operation has been successfuly started.


How reproducible
================

100 %

Steps to Reproduce
==================

1. Create GlusterFS volume
2. Enable scrub on the volume
3. Load some data there
4. Run ondeman scrub

Actual results
==============

As you can see here:

```
# gluster volume bitrot volume_beta_arbiter_2_plus_1x2 scrub ondemand
volume bitrot: success
```

the output is very short and could be misinterpreted as a status of scrub operation.
It doesn't directly mentions start of scrub operation.

Expected results
================

The output of `gluster volume bitrot VOLNAME scrub ondemand` command should state
that scrub ondemand operation has been started.

Comment 1 Worker Ant 2018-01-26 19:57:26 UTC
REVIEW: https://review.gluster.org/19344 (bitrot : improved cli report after bitrot operatoin) posted (#1) for review on master by Sunny Kumar

Comment 2 Worker Ant 2018-02-01 03:29:52 UTC
COMMIT: https://review.gluster.org/19344 committed in master by "Kotresh HR" <khiremat@redhat.com> with a commit message- bitrot : improved cli report after bitrot operatoin

Improved cli report post bitrot opertaion as previously it was
showing output "volume bitrot: success" for all the sucessfull
bitrot operations (enable, disable or scrub options).

Change-Id: I0857e99f3956221a51cfd1b29a90e1038b90570f
BUG: 1539166
Signed-off-by: Sunny Kumar <sunkumar@redhat.com>

Comment 3 Shyamsundar 2018-06-20 17:58:10 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-v4.1.0, please open a new bug report.

glusterfs-v4.1.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://lists.gluster.org/pipermail/announce/2018-June/000102.html
[2] https://www.gluster.org/pipermail/gluster-users/


Note You need to log in before you can comment on or make changes to this bug.