Bug 1539193 - RFE: Support for mm kubernetes plugin
Summary: RFE: Support for mm kubernetes plugin
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: rsyslog
Version: 7.4
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: rc
: ---
Assignee: Rich Megginson
QA Contact: Anping Li
Tomas Capek
URL:
Whiteboard:
: 1598865 (view as bug list)
Depends On:
Blocks: 1477664 1564074 1589924 1590582 1614432 1625935
TreeView+ depends on / blocked
 
Reported: 2018-01-26 21:39 UTC by Ruchika K
Modified: 2018-11-01 17:26 UTC (History)
16 users (show)

Fixed In Version: rsyslog-8.24.0-33.el7
Doc Type: Enhancement
Doc Text:
New *rsyslog* module: *mmkubernetes* To enable scenarios using *rsyslog* in favor of other log collectors and where kubernetes container metadata are required, a new *mmkubernetes* module has been added to Red Hat Enterprise Linux.
Clone Of:
: 1564074 1564077 1589924 1614432 (view as bug list)
Environment:
Last Closed: 2018-10-30 10:17:00 UTC


Attachments (Terms of Use)
patch - squashed from upstream 2 patches (60.58 KB, patch)
2018-04-04 22:34 UTC, Rich Megginson
no flags Details | Diff
docs patch for rsyslog-doc (11.61 KB, patch)
2018-04-04 23:53 UTC, Rich Megginson
no flags Details | Diff


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2018:3135 None None None 2018-10-30 10:19:08 UTC
Github rsyslog rsyslog-doc pull 720 None None None 2018-08-22 14:42:06 UTC
Github rsyslog rsyslog pull 2466 None None None 2018-03-02 14:10:55 UTC
Github rsyslog rsyslog pull 2805 None None None 2018-06-28 07:32:24 UTC
Github rsyslog rsyslog pull 2857 None None None 2018-07-20 15:21:49 UTC
Github rsyslog rsyslog pull 2881 None None None 2018-07-27 13:36:54 UTC
Red Hat Bugzilla 1589924 None CLOSED RFE: Several fixes for mmkubernetes 2019-07-17 14:11:51 UTC
Red Hat Bugzilla 1590582 None CLOSED mmkubernetes - use version=2 in rulebase files to avoid memory leak 2019-07-17 14:11:51 UTC
Red Hat Bugzilla 1596265 None CLOSED mmkubernetes - memory error - calling fclose on NULL 2019-07-17 14:11:51 UTC
Red Hat Bugzilla 1598865 None CLOSED mmkubernetes - pod names may contain dots - fix filename rule 2019-07-17 14:11:51 UTC
Red Hat Bugzilla 1609023 None CLOSED mmkubernetes - stops working when non-kubernetes container name is read 2019-07-17 14:11:51 UTC


Description Ruchika K 2018-01-26 21:39:33 UTC
Description of problem:
This use case is applicable to openshift customers utilizing an enterprise grade external logging solution. A possible solution might be to use rsyslog to send container and host logs to an external logger (such as Log Insight). This plugin then allows the container metadata parsing/filtering. The support for this plugin is required to allow for an alternative logging solution. 

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 4 Rich Megginson 2018-04-04 22:34:49 UTC
Created attachment 1417480 [details]
patch - squashed from upstream 2 patches

The commit is the two upstream patches squashed together to make it easier to merge.
Please review the merge request at https://gitlab.cee.redhat.com/rsyslog/rsyslog/merge_requests/4

Comment 5 Rich Megginson 2018-04-04 23:53:58 UTC
Created attachment 1417483 [details]
docs patch for rsyslog-doc

Comment 6 Jiří Vymazal 2018-04-09 08:31:13 UTC
The mmkubernetes plugin is now available in Fedora - see bug 1564077

Comment 33 Jiří Vymazal 2018-08-06 14:17:24 UTC
*** Bug 1598865 has been marked as a duplicate of this bug. ***

Comment 37 Anping Li 2018-08-22 08:54:42 UTC
As KubernetesURL default https://kubernetes.default.svc.cluster.local:443, Is it still a  mandatory parameter? Shall we update the doc patch?

Comment 38 Rich Megginson 2018-08-22 14:42:06 UTC
(In reply to Anping Li from comment #37)
> As KubernetesURL default https://kubernetes.default.svc.cluster.local:443,
> Is it still a  mandatory parameter? Shall we update the doc patch?

Yes - https://github.com/rsyslog/rsyslog-doc/pull/720

Comment 40 Anping Li 2018-09-04 16:36:15 UTC
@Dalibor, the https://github.com/rsyslog/rsyslog-doc/pull/720 looks good to me. You can move to verified when the PR are merged.

Comment 47 errata-xmlrpc 2018-10-30 10:17:00 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2018:3135


Note You need to log in before you can comment on or make changes to this bug.