Bug 15393 - Minor bug in fortune(6) database
Minor bug in fortune(6) database
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: fortune-mod (Show other bugs)
6.1
i386 Linux
low Severity low
: ---
: ---
Assigned To: Mike A. Harris
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-08-04 10:25 EDT by Need Real Name
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-11-13 16:08:00 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
fixes wrong author (420 bytes, patch)
2003-03-04 16:33 EST, Sven Neuhaus
no flags Details | Diff

  None (edit)
Description Need Real Name 2000-08-04 10:25:17 EDT
Hi.

        I am working on a RedHat 6.1 box, and recently found a minor
bug in the fortune database. :-)  It gave the following:

   A horse!  A horse!  My kingdom for a horse!
		-- Wm. Shakespeare, "Henry VI"

which is a mis-attribution since the line is (AFAIK and according to
Bartlett's) from "Richard III" rather than "Henry VI".  I wanted to
send a bug report to this effect, but I couldn't figure out who
maintains the 'fortune' program (at least the version found on RH6.1).
The man page simply lists it as being "based on the NetBSD fortune
1.4" and coming from "BSD Experimental 19 April 94 [May. 97]".

	Is this the right forum for a bug in the content of the database?

Dan

P.S.  Yes, I *know* that this is completely imbecilic, but there's no
point in letting mis-information propagate. :-) If the mis-attribution
is the point of the joke, then it's too bloody subtle for me....
Comment 1 Mike A. Harris 2000-11-19 22:15:36 EST
As you already pointed out yourself, this is not anything critical,
and is not a bug.  If you cannot track down the author, send me a
diff against the sources for any misattributions you find, and I'll
either include them or try and track down the author myself.

Other than that, this bug will be closed.

Comment 2 Sven Neuhaus 2003-03-04 16:32:49 EST
Here is another error in one of the fortunes. I'm attaching a diff.
Comment 3 Sven Neuhaus 2003-03-04 16:33:46 EST
Created attachment 90468 [details]
fixes wrong author

Please reopen the bug until this is fixed. Thanks.
Comment 4 Mike A. Harris 2003-03-04 22:23:17 EST
Red Hat Linux 6.1 is long since unsupported.  This type of change is not
worthy of erratum for any distribution release, and is of such a trivial
nature, that it isn't worth the attention.  This bug will not be reopened,
nor fixed.
Comment 5 Mike A. Harris 2003-03-04 22:24:06 EST
I'd also like to add, that new bug reports should be filed as new bug
reports, not added to 3 year old closed bug reports.  Don't bother filing
this one as a new bug report however, as it wont ever be changed.

Note You need to log in before you can comment on or make changes to this bug.