Bug 1539379 - [RFE] add API to assign alert profiles to the enterprise
Summary: [RFE] add API to assign alert profiles to the enterprise
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: API
Version: 5.9.0
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: GA
: 5.10.0
Assignee: Gregg Tanzillo
QA Contact: Parthvi Vala
URL:
Whiteboard: container
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-01-28 12:37 UTC by Elad Alfassa
Modified: 2019-02-07 23:01 UTC (History)
6 users (show)

Fixed In Version: 5.10.0.0
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-02-07 23:01:05 UTC
Category: ---
Cloudforms Team: CFME Core
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHSA-2019:0212 None None None 2019-02-07 23:01:11 UTC

Description Elad Alfassa 2018-01-28 12:37:48 UTC
We need an API to assign alert profiles to the Enterprise to automate deployments of CFME.

This functionality exists in the UI under "Control->Explorer->Alert Profiles -> select an alert profile -> configuration -> edit assignments for this alert profile", but there's no API for it yet.

Comment 3 CFME Bot 2018-03-20 19:46:27 UTC
New commit detected on ManageIQ/manageiq-api/master:

https://github.com/ManageIQ/manageiq-api/commit/09a440a7ccb516510716baee68d9ee3250f554b0
commit 09a440a7ccb516510716baee68d9ee3250f554b0
Author:     Jillian Tullo <jtullo@redhat.com>
AuthorDate: Thu Mar 15 15:55:33 2018 -0400
Commit:     Jillian Tullo <jtullo@redhat.com>
CommitDate: Thu Mar 15 15:55:33 2018 -0400

    Unassign alert definition profiles

    Fixes https://bugzilla.redhat.com/show_bug.cgi?id=1539379

 app/controllers/api/alert_definition_profiles_controller.rb | 18 +
 config/api.yml | 4 +
 spec/requests/alert_definition_profiles_spec.rb | 52 +
 3 files changed, 74 insertions(+)

Comment 7 Parthvi Vala 2018-11-13 06:52:03 UTC
FIXED. Verified on 5.10.0.23.20181106165157_92dd189.

Turns out you were right Gregg. I collected all tags via API and selected one at random("roles/change_managers") from the list. I'm still not sure why "roles/change_managers" did not work. I then selected one tag from the list on UI and it worked. Tested the tag "department/accounting" with both name and href, and it worked fine.

Comment 8 errata-xmlrpc 2019-02-07 23:01:05 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHSA-2019:0212


Note You need to log in before you can comment on or make changes to this bug.