Bug 1539616 - Deployment fails with ERROR: Failed to validate: Failed to validate: resources[0]: The Resource Type (OS::TripleO::SwiftStorage::Ports::ManagementPort) could not be found.",
Summary: Deployment fails with ERROR: Failed to validate: Failed to validate: resource...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-tripleo-heat-templates
Version: 11.0 (Ocata)
Hardware: Unspecified
OS: Unspecified
urgent
urgent
Target Milestone: z4
: 11.0 (Ocata)
Assignee: Christian Schwede (cschwede)
QA Contact: Mike Abrams
URL:
Whiteboard:
Depends On:
Blocks: 1438608 1544802
TreeView+ depends on / blocked
 
Reported: 2018-01-29 10:39 UTC by Marius Cornea
Modified: 2018-02-13 16:36 UTC (History)
12 users (show)

Fixed In Version: openstack-tripleo-heat-templates-6.2.7-2.el7ost
Doc Type: Bug Fix
Doc Text:
Previously, deployment would fail when using additional object storages. This was the result of inconsistent network port names. With this update, port names are now consistent across all templates, and deployment succeeds when using additional object storage nodes.
Clone Of:
: 1544802 (view as bug list)
Environment:
Last Closed: 2018-02-13 16:36:56 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2018:0310 normal SHIPPED_LIVE Red Hat OpenStack Platform 11.0 director Bug Fix Advisory 2018-02-14 00:13:02 UTC
OpenStack gerrit 541721 None None None 2018-02-07 14:04:10 UTC

Description Marius Cornea 2018-01-29 10:39:05 UTC
Description of problem:
Deployment fails with ERROR: Failed to validate: Failed to validate: resources[0]: The Resource Type (OS::TripleO::SwiftStorage::Ports::ManagementPort) could not be found.",

Version-Release number of selected component (if applicable):
openstack-tripleo-heat-templates-6.2.7-1.el7ost.noarch

How reproducible:
100%

Steps to Reproduce:
1. Deploy OSP11 with swift storage nodes

Actual results:
Deployment fails with ERROR: Failed to validate: Failed to validate: resources[0]: The Resource Type (OS::TripleO::SwiftStorage::Ports::ManagementPort) could not be found.",

Expected results:
Deployment succeeds. 

Additional info:

https://review.openstack.org/#/c/516023/ changed the OS::TripleO::SwiftStorage::Ports* resources to OS::TripleO::ObjectStorage::Port* naming but the ports in https://github.com/openstack/tripleo-heat-templates/blob/stable/ocata/puppet/objectstorage-role.yaml#L181-L221 are still using the OS::TripleO::SwiftStorage::Ports type for the ports.

Comment 8 errata-xmlrpc 2018-02-13 16:36:56 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:0310


Note You need to log in before you can comment on or make changes to this bug.