Bug 153969 - kernel panic when removing active USB serial converter used as serial console
Summary: kernel panic when removing active USB serial converter used as serial console
Status: CLOSED DUPLICATE of bug 153967
Alias: None
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: kernel (Show other bugs)
(Show other bugs)
Version: 3.0
Hardware: ia64 Linux
medium
high
Target Milestone: ---
Assignee: Dave Jones
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-04-06 06:26 UTC by Richard Horwood
Modified: 2015-01-04 22:18 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-04-06 06:28:41 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Richard Horwood 2005-04-06 06:26:48 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; SunOS sun4u; en-US; rv:1.7.6) Gecko/20050322 Firefox/1.0.2

Description of problem:
Installed a belkin USB to serial converter into system, and set up to work as a serial console for the system.

Kernel recognises the adapter, and serial console works very well.

/etc/inittab contains the line:
cu:2345:respawn:/sbin/agetty -t60 -f /etc/issue.usb 19200 /dev/ttyUSB0

If the USB to serial converter is unplugged when an active agetty is running, the kernel panics.

Version-Release number of selected component (if applicable):
kernel-2.4.21-31.EL

How reproducible:
Always

Steps to Reproduce:
1. Insert USB to serial adapter
2. If not already running, start agetty process on /dev/ttyUSB0 (or whatever tty)
3. unplug USB to serial adapter
  

Actual Results:  System fall down go boom.

Kernel panic, system halted.

Expected Results:  The kernel should recognise the event and bypass any processess attached to that tty

Additional info:

Comment 1 Richard Horwood 2005-04-06 06:28:41 UTC

*** This bug has been marked as a duplicate of 153967 ***


Note You need to log in before you can comment on or make changes to this bug.