Bug 1539765 - Auto-Sync - network rename on provider does not trigger rename in engine
Summary: Auto-Sync - network rename on provider does not trigger rename in engine
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: ovirt-engine
Classification: oVirt
Component: BLL.Network
Version: future
Hardware: Unspecified
OS: Unspecified
high
medium vote
Target Milestone: ovirt-4.2.4
: ---
Assignee: Dominik Holler
QA Contact: Michael Burman
URL:
Whiteboard:
Depends On:
Blocks: 1511823
TreeView+ depends on / blocked
 
Reported: 2018-01-29 14:57 UTC by Mor
Modified: 2018-06-26 08:44 UTC (History)
5 users (show)

Fixed In Version: ovirt-engine-4.2.4
Doc Type: Enhancement
Doc Text:
Feature: External network rename on provider is reflected in engine Reason: The name of an external network in engine should be consistent with the name of the same network on the provider. Result: Renaming an external network on the provider is reflected in engine.
Clone Of:
Environment:
Last Closed: 2018-06-26 08:44:18 UTC
oVirt Team: Network
rule-engine: ovirt-4.2+
ylavi: exception+


Attachments (Terms of Use)
ovirt-provider-ovn engine logs (555.30 KB, application/octet-stream)
2018-01-29 14:57 UTC, Mor
no flags Details


Links
System ID Priority Status Summary Last Updated
oVirt gerrit 87604 master MERGED core: Update external network during sync 2018-03-20 07:43:31 UTC
oVirt gerrit 89273 ovirt-engine-4.2 MERGED core: Update external network during sync 2018-04-26 06:07:59 UTC
oVirt gerrit 90655 model_4.2 MERGED Document new update feature of auto_sync 2018-05-04 06:34:10 UTC
oVirt gerrit 90891 model_4.2 MERGED Document new update feature of auto_sync 2018-05-04 06:34:35 UTC

Description Mor 2018-01-29 14:57:51 UTC
Created attachment 1387836 [details]
ovirt-provider-ovn engine logs

Description of problem:
When renaming existing network in the provider, auto-sync does not update the network name in engine.

Version-Release number of selected component (if applicable):
RHV 4.2.1.3-0.1.el7

How reproducible:
100%

Steps to Reproduce:
1. Create network on provider 'OVN_NET'.
2. Wait for auto-sync cycle.
3. Update the network name to 'OVN_NET_NEW'.

Actual results:
Engine still shows the obsolete network name - 'OVN_NET'.

Expected results:
Engine should update the name field of the oVirt network.

Additional info:
Look for 'sample_network_*' (wildcard) in the logs.

Comment 1 Michael Burman 2018-05-27 08:01:34 UTC
Dominik,
Just to clear something, do we allow to rename the ovn network via the engine or not? currently it's possible to do so via the engine(we have no validation for it) and after the sync the name of the ovn network returns to the origin, is that the expected behaviour in such case?

Comment 2 Dominik Holler 2018-05-28 08:10:50 UTC
(In reply to Michael Burman from comment #1)
> Dominik,
> Just to clear something, do we allow to rename the ovn network via the
> engine or not? currently it's possible to do so via the engine(we have no
> validation for it) and after the sync the name of the ovn network returns to
> the origin, is that the expected behaviour in such case?

This is the expected behavior in the current ovirt-4.2. In ovirt-4.3 the renaming is already blocked. If ovirt-4.3's behavior should be backported to ovirt-4.2, a new bug is required.

Comment 3 Michael Burman 2018-05-28 09:33:57 UTC
Verified on - 4.2.4-0.1.el7

Comment 4 Michael Burman 2018-05-29 06:11:25 UTC
(In reply to Dominik Holler from comment #2)
> (In reply to Michael Burman from comment #1)
> > Dominik,
> > Just to clear something, do we allow to rename the ovn network via the
> > engine or not? currently it's possible to do so via the engine(we have no
> > validation for it) and after the sync the name of the ovn network returns to
> > the origin, is that the expected behaviour in such case?
> 
> This is the expected behavior in the current ovirt-4.2. In ovirt-4.3 the
> renaming is already blocked. If ovirt-4.3's behavior should be backported to
> ovirt-4.2, a new bug is required.

We decided that we would like to have in 4.2 as well.
BZ 1583486

Comment 5 Sandro Bonazzola 2018-06-26 08:44:18 UTC
This bugzilla is included in oVirt 4.2.4 release, published on June 26th 2018.

Since the problem described in this bug report should be
resolved in oVirt 4.2.4 release, it has been closed with a resolution of CURRENT RELEASE.

If the solution does not work for you, please open a new bug report.


Note You need to log in before you can comment on or make changes to this bug.