Bug 1539773
| Summary: | Slow upload image throughput times out and is paused by system without informational message | ||||||||
|---|---|---|---|---|---|---|---|---|---|
| Product: | [oVirt] ovirt-engine | Reporter: | Kevin Alon Goldblatt <kgoldbla> | ||||||
| Component: | BLL.Storage | Assignee: | Daniel Erez <derez> | ||||||
| Status: | CLOSED CURRENTRELEASE | QA Contact: | Kevin Alon Goldblatt <kgoldbla> | ||||||
| Severity: | medium | Docs Contact: | |||||||
| Priority: | unspecified | ||||||||
| Version: | 4.2.0 | CC: | amureini, bugs, derez, ebenahar, kgoldbla, lveyde | ||||||
| Target Milestone: | ovirt-4.2.2 | Flags: | rule-engine:
ovirt-4.2+
|
||||||
| Target Release: | --- | ||||||||
| Hardware: | Unspecified | ||||||||
| OS: | Unspecified | ||||||||
| Whiteboard: | |||||||||
| Fixed In Version: | ovirt-engine-4.2.2.1 | Doc Type: | If docs needed, set a value | ||||||
| Doc Text: | Story Points: | --- | |||||||
| Clone Of: | Environment: | ||||||||
| Last Closed: | 2018-03-29 11:09:55 UTC | Type: | Bug | ||||||
| Regression: | --- | Mount Type: | --- | ||||||
| Documentation: | --- | CRM: | |||||||
| Verified Versions: | Category: | --- | |||||||
| oVirt Team: | Storage | RHEL 7.3 requirements from Atomic Host: | |||||||
| Cloudforms Team: | --- | Target Upstream Version: | |||||||
| Embargoed: | |||||||||
| Attachments: |
|
||||||||
Why is this a UX bug? Created attachment 1397865 [details]
engine and vdsm logs
Added new logs:
* Can you please also attach the console log from the browser? * Is it the same behaviour on firefox and chrome? (In reply to Daniel Erez from comment #4) > * Can you please also attach the console log from the browser? > * Is it the same behaviour on firefox and chrome? Just tried the scenario with latest build and chrome - got to expected audit log: "UPLOAD_IMAGE_XHR_TIMEOUT_ERROR(1,061), Unable to upload image to disk da83c14b-3d41-4c75-bfe4-4b0306bfcc01 due to a request timeout error. The upload bandwidth might be too slow. Please try to reduce the chunk size: 'engine-config -s UploadImageChunkSizeKB=new_value" So, to understand what's the difference between our envs, can you try it both with chrome and firefox? Also, which exact build of engine are you using? I tested with the following code: ------------------------------------- ovirt-engine-4.2.2-0.1.el7.noarch vdsm-4.20.18-1.el7ev.x86_64(In reply to Daniel Erez from comment #4) > * Can you please also attach the console log from the browser? > * Is it the same behaviour on firefox and chrome? I tested with the following code: ------------------------------------- ovirt-engine-4.2.2-0.1.el7.noarch vdsm-4.20.18-1.el7ev.x86_64 Verified with the following code: -------------------------------------- ovirt-engine-4.2.2.1-0.1.el7.noarch vdsm-4.20.19-1.el7ev.x86_64 Verified with the following scenario: -------------------------------------- 1. Uploaded a large(2.5gb) image over the WIFI 2. After about 150mb a message the "Paused by system" message is displayed 3. Checking the events tab displays the relevant message "Unable to upload image to disk 20949ead-2cf1-4958-a430-d102b3605b42 due to a request timeout error. The upload bandwidth might be too slow. Please try to reduce the chunk size: 'engine-config -s UploadImageChunkSizeKB=new_value" 4.However when selecting the specific disk in the Disks tab and hovering over the "Paused by system" message there is no tool tip any more. Was this intentional or a new bug? Moving to VERIFIED This bugzilla is included in oVirt 4.2.2 release, published on March 28th 2018. Since the problem described in this bug report should be resolved in oVirt 4.2.2 release, it has been closed with a resolution of CURRENT RELEASE. If the solution does not work for you, please open a new bug report. |
Created attachment 1387851 [details] vdsm, server, engine logs Description of problem: when uploading an image and the upload throughput is slow, it times out and the upload it paused by system without giving any informative message with corrective action. Now you get; 2018-01-29 15:24:22,806+02 WARN [org.ovirt.engine.core.dal.dbbroker.auditloghandling.AuditLogDirector] (default task-13) [526825a6-2c28-466f-8668-2693509c6de8] EVENT_ID: UPLOAD_IMAGE_NETWORK_ERROR(1,038), Unabl e to upload image to disk d128c1a0-1e25-4bf6-9f32-70de9a5125c4 due to a network error. Make sure ovirt-imageio-proxy service is installed and configured, and ovirt-engine's certificate is registered as a valid C A in the browser. The certificate can be fetched from https://<engine_url>/ovirt-engine/services/pki-resource?resource=ca-certificate&format=X509-PEM-CA engine.log; -------------------------------------- Version-Release number of selected component (if applicable): ovirt-engine-4.2.1.3-0.1.el7.noarch vdsm-4.20.17-11.gite2d6775.el7.centos.x86_64 events: ------------- Unable to upload image to disk d128c1a0-1e25-4bf6-9f32-70de9a5125c4 due to a network error. Make sure ovirt-imageio-proxy service is installed and configured, and ovirt-engine's certificate is registered as a valid CA in the browser. The certificate can be fetched from https://<engine_url>/ovirt-engine/services/pki-resource?resource=ca-certificate&format=X509-PEM-CA How reproducible: 100% Steps to Reproduce: 1. Start uploading an iso image over a WIFI with up to 3mb upload throuhgput 2. After a few(+- 20mb) of data, the upload is paused with message "paused by system and the tool tip displays "" 3. Actual results: An unrelated event message is displayed Expected results: Should display a message indicating the upload speed is too slow and caused the time out. Also add a message as to how to change the timeout for this operation in "engine-config -s UploadImageChunkSizeKB=xxxxx" Additional info: See logs