Bug 153993 - D-Link Bluetooth DBT-120 adaptor doesn't work
Summary: D-Link Bluetooth DBT-120 adaptor doesn't work
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: udev
Version: 4
Hardware: powerpc
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Harald Hoyer
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks: fedora-ppc
TreeView+ depends on / blocked
 
Reported: 2005-04-06 14:45 UTC by Andrew Cagney
Modified: 2007-11-30 22:11 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-04-21 13:07:46 UTC


Attachments (Terms of Use)

Description Andrew Cagney 2005-04-06 14:45:11 UTC
(is this a kernel, doco, anaconda, or ... bug?)

The DBT-120 adaptor doesn't work out-of-the-box.  The driver reports;

bcm203x_probe: Mini driver request failed
bcm203x: probe of 1-1:1.0 failed with error -5

You need to fetch the firmware from:

http://www.bluez.org/download.html

and install the files:

BCM2033-MD.hex BCM2033-FW.bin

in /lib/firmware (the firmware tar ball will do it if you do: ./configure; make;
make install).

Comment 1 Colin Charles 2005-04-07 05:37:51 UTC
FWIW, tried it on Rawhide/x86 (its almost FC4test2 now)
Bluetooth: Core ver 2.7
NET: Registered protocol family 31
Bluetooth: HCI device and connection manager initialized
Bluetooth: HCI socket layer initialized
Bluetooth: HCI USB driver ver 2.8
usbcore: registered new driver hci_usb

And it worked. I recall this working with Rawhide (pre-fc4t1) on powerpc as
well, however I haven't rolled an install out in a while (and am away from my
ppc boxes now)

lsusb reports the adapter (a dbt-120) as:
Bus 003 Device 003: ID 0a12:0001 Cambridge Silicon Radio, Ltd Bluetooth Dongle
(HCI mode)

IIRC, on irc, you reported your lsusb output as being:
<cagney> Bus 001 Device 002: ID 0a5c:2033 Broadcom Corp. BCM2033 Bluetooth

So guess this isn't the first time they release the same product model and
change the internals of it with a different manufacturer..

Comment 2 Andrew Cagney 2005-04-07 16:40:14 UTC
PS: The above, while correct, isn't working.

(Following DWMW2's pointer) I'm fi that /etc/hotplug/firmware.agent fails with:

+ cp /lib/firmware/BCM2033-MD.hex /sys//class/firmware/1-1/data
cp: cannot create regular file `/sys//class/firmware/1-1/data': No such file or
directory
+ echo 0
/etc/hotplug/firmware.agent: line 49: /sys//class/firmware/1-1/loading: No such
file or directory


Comment 4 Harald Hoyer 2005-04-11 15:28:39 UTC
could you try:
ftp://people.redhat.com/harald/udev/udev-056-1.src.rpm

Comment 5 Harald Hoyer 2005-04-11 16:03:01 UTC
needs udev-056 and 2.6.12 or patch for 2.6.11 
http://kernel.org/pub/linux/kernel/people/gregkh/gregkh-2.6/patches/driver/firmware-timeout.patch

Comment 7 Ziga Mahkovec 2005-04-12 13:51:11 UTC
I've also been having issues with firmware loading (ipw2100) and it turned out
to be a problem with the initial event timeout in udevd:

https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=145283#c10

This too is fixed in udev-056, but doesn't require the kernel patch.  So if
firmware loading only fails during boot, it's likely a startup timeout issue. 
The kernel patch avoids the issue completely by allowing firmware events to
bypass the udevd queue.

Comment 8 Andrew Cagney 2005-04-12 14:56:39 UTC
Harold,

Should 2.6.11-1.1236_FC4 and udev-050-10 work (it doesn't appear to) or do I
also need to also build / install the udev-056 rpm?

$ uname -a
Linux localhost.localdomain 2.6.11-1.1236_FC4 #1 Mon Apr 11 12:23:42 EDT 2005
ppc ppc ppc GNU/Linux
$ rpm -q udev
udev-050-10
$ sudo hciconfig
$ dmesg | tail
ADB keyboard at 2, handler 1
ADB mouse at 3, handler set to 4 (trackpad)
adb: finished probe task...
usb 1-1: new full speed USB device using ohci_hcd and address 2
Bluetooth: Broadcom Blutonium firmware driver ver 1.0
Bluetooth: HCI USB driver ver 2.8
bcm203x_probe: Mini driver request failed
bcm203x: probe of 1-1:1.0 failed with error -5
usbcore: registered new driver bcm203x
usbcore: registered new driver hci_usb
$


Comment 9 Harald Hoyer 2005-04-12 15:28:04 UTC
Andrew, my name is Harald and please test udev-056.

Comment 10 Andrew Cagney 2005-04-12 22:29:37 UTC
Ok, I've tested udev-056-1 and finally get:
# hciconfig
hci0:   Type: USB
        BD Address: 00:80:C8:50:F9:5C ACL MTU: 377:10 SCO MTU: 16:0
        UP RUNNING PSCAN ISCAN
        RX bytes:101 acl:0 sco:0 events:13 errors:0
        TX bytes:300 acl:0 sco:0 commands:13 errors:0
my phone sees my mac; but not the reverse; try again, ah there it is now for a
dial out ...



Note You need to log in before you can comment on or make changes to this bug.