Note: This bug is displayed in read-only format because the product is no longer active in Red Hat Bugzilla.

Bug 1540096

Summary: Suggest to give the selection or hint of the glusterFS volume replica(at least 3) while deploying HE via cockpit with gluster based otopi
Product: [oVirt] cockpit-ovirt Reporter: Yihui Zhao <yzhao>
Component: Hosted EngineAssignee: Phillip Bailey <phbailey>
Status: CLOSED CURRENTRELEASE QA Contact: Yihui Zhao <yzhao>
Severity: medium Docs Contact:
Priority: medium    
Version: 0.11.6CC: bugs, cshao, huzhao, phbailey, qiyuan, rbarry, sbonazzo, weiwang, yaniwang, ycui, ylavi
Target Milestone: ovirt-4.2.5Keywords: EasyFix
Target Release: 0.11.29Flags: rule-engine: ovirt-4.2+
ylavi: exception+
cshao: testing_ack+
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: cockpit-ovirt-0.11.29-1 Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2018-07-31 15:31:25 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: Integration RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Embargoed:
Bug Depends On:    
Bug Blocks: 1596277    
Attachments:
Description Flags
glusterfs_error.png
none
glusterfs_storage.png none

Description Yihui Zhao 2018-01-30 09:31:51 UTC
Created attachment 1388240 [details]
glusterfs_error.png

Description of problem: 
Suggest to give the selection or hint of the glusterFS volume replica(at least 3) while deploying HE via cockpit with gluster based otopi.


Version-Release number of selected component (if applicable): 
cockpit-ws-157-1.el7.x86_64
cockpit-bridge-157-1.el7.x86_64
cockpit-storaged-157-1.el7.noarch
cockpit-dashboard-157-1.el7.x86_64
cockpit-157-1.el7.x86_64
cockpit-ovirt-dashboard-0.11.6-0.1.el7ev.noarch
cockpit-system-157-1.el7.noarch
ovirt-hosted-engine-setup-2.2.8-2.el7ev.noarch
ovirt-hosted-engine-ha-2.2.4-1.el7ev.noarch
rhvm-appliance-4.2-20180125.0.el7.noarch
rhvh-4.2.1.2-0.20180126.0+1


How reproducible: 
100% 


Steps to Reproduce: 
1. Clean install latest RHVH4.2.1 with ks(rhvh-4.2.1.2-0.20180126.0+1)
2. Deploy HE via cockpit with glusterfs  storage based otopi deployment


Actual results: 
1. After step 2, deploy failed and raise the error :
Failed to execute stage 'Environment customization': GlusterFS Volume is not using replica 3
 Hosted Engine deployment failed 


Expected results: 


Additional info:

Comment 1 Yihui Zhao 2018-01-30 09:33:15 UTC
Created attachment 1388241 [details]
glusterfs_storage.png

Comment 2 Ryan Barry 2018-01-30 09:36:21 UTC
This seems like a gdeploy problem rather than hosted engine.

Comment 3 Yihui Zhao 2018-01-30 09:50:06 UTC
(In reply to Ryan Barry from comment #2)
> This seems like a gdeploy problem rather than hosted engine.

I didn't use the gdeploy tool to setup the glusterfs cluster. Just setup the glusterfs cluster manually. While deploying SHE with glusterfs, it should be  at least 3 glusterFS volume replica for HE deployment. I just think that give a  hint or warning for user on cockpit about glusterFS volume replica rather than raising the error and ending the deployment.

Comment 4 Ryan Barry 2018-01-30 11:09:42 UTC
I'm not sure whether or not a preconfigured volume is actually a supported use case or not. I imagine that it would be, but I would expect cockpit users to also use the cockpit gdeploy plugin.

Yaniv, opinions?

Comment 5 Yaniv Lavi 2018-02-06 10:50:39 UTC
(In reply to Ryan Barry from comment #4)
> I'm not sure whether or not a preconfigured volume is actually a supported
> use case or not. 

It is.

> I imagine that it would be, but I would expect cockpit
> users to also use the cockpit gdeploy plugin.

It doesn't have to be with local which is the GDeploy use case.

> 
> Yaniv, opinions?

We are also adding single brick volume support in 4.2, so it can be 1 or 3, but not 2.
We can add text after selecting Gluster storage on this.

Comment 6 Yaniv Kaul 2018-03-13 17:54:17 UTC
We are moving away from otopi. Lowering severity and pushing to 4.2.4.

Comment 7 Phillip Bailey 2018-06-13 15:50:42 UTC
This issue isn't being validated in the ansible flow. Validating it within setup would require duplicating VDSM code, which should be avoided as it introduces maintenance issues. Validation should occur on the engine side, but I'm not sure what is currently being done there.

A informative message can still be displayed, of course. If you would like one added, please propose the contents of the message.

Comment 8 Yaniv Lavi 2018-06-19 12:56:42 UTC
(In reply to Phillip Bailey from comment #7)
> This issue isn't being validated in the ansible flow. Validating it within
> setup would require duplicating VDSM code, which should be avoided as it
> introduces maintenance issues. Validation should occur on the engine side,
> but I'm not sure what is currently being done there.
> 
> A informative message can still be displayed, of course. If you would like
> one added, please propose the contents of the message.

Just test would be good in my opinion.

Comment 9 Phillip Bailey 2018-06-19 14:19:11 UTC
(In reply to Yaniv Lavi from comment #8)
> 
> Just test would be good in my opinion.

What should the message say? Is something like "Please note that only replica 1 and replica 3 volumes are supported." sufficient?

Comment 10 Yaniv Lavi 2018-06-24 14:33:58 UTC
(In reply to Phillip Bailey from comment #9)
> (In reply to Yaniv Lavi from comment #8)
> > 
> > Just text would be good in my opinion.
> 
> What should the message say? Is something like "Please note that only
> replica 1 and replica 3 volumes are supported." sufficient?

Yes, that fine.

Comment 11 Yihui Zhao 2018-07-02 07:09:49 UTC
Tested with cockpit-ovirt-0.11.29-1, when using the glusterfs storage, cockpit gives the hint " Please note that only replica 1 and replica 3 volumes are supported."

Will change the bug's status to verified while it becomes ON_QA.

Comment 12 Yihui Zhao 2018-07-06 02:07:38 UTC
According to Comment 11, change this bug's status to verified.

Comment 13 Sandro Bonazzola 2018-07-31 15:31:25 UTC
This bugzilla is included in oVirt 4.2.5 release, published on July 30th 2018.

Since the problem described in this bug report should be
resolved in oVirt 4.2.5 release, it has been closed with a resolution of CURRENT RELEASE.

If the solution does not work for you, please open a new bug report.