Bug 1540221 - gcc: Stack spilling in i686 -fstack-clash-protection prologue neglects %esp change
Summary: gcc: Stack spilling in i686 -fstack-clash-protection prologue neglects %esp c...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: gcc
Version: rawhide
Hardware: i686
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Jeff Law
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-01-30 13:51 UTC by Florian Weimer
Modified: 2018-03-06 17:31 UTC (History)
8 users (show)

Fixed In Version: gcc-8.0.1-0.9.fc28 gcc-7.3.1-3.fc27 gcc-7.3.1-5.fc27
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-03-06 17:31:32 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
GNU Compiler Collection 84128 None None None 2018-01-30 13:51:34 UTC

Description Florian Weimer 2018-01-30 13:51:35 UTC
See bug 1515865 comment 9.

This is another wrong-code bug in -fstack-clash-protection on i686.  It causes miscompilation of pcre and pcre2.  Filing downstream for tracking purposes.  The upstream bug has a reproducer.

Comment 1 Jeff Law 2018-02-01 16:38:21 UTC
Fixed upstream.  Builds spinning for f27 and rawhide.

Comment 2 Petr Pisar 2018-02-02 11:14:32 UTC
Thanks. I confirm gcc-8.0.1-0.9.fc28 works for me.

Comment 3 Fedora Update System 2018-03-04 19:25:47 UTC
gcc-7.3.1-5.fc27 has been submitted as an update to Fedora 27. https://bodhi.fedoraproject.org/updates/FEDORA-2018-dd08df5b34

Comment 4 Fedora Update System 2018-03-05 20:11:34 UTC
gcc-7.3.1-5.fc27 has been pushed to the Fedora 27 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2018-dd08df5b34

Comment 5 Fedora Update System 2018-03-06 17:31:32 UTC
gcc-7.3.1-5.fc27 has been pushed to the Fedora 27 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.