Bug 154033 - htmlview -remote option shows an unexpected page with a strange error message
htmlview -remote option shows an unexpected page with a strange error message
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: htmlview (Show other bugs)
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Christopher Aillon
Depends On:
  Show dependency treegraph
Reported: 2005-04-06 13:57 EDT by Noriko Hosoi
Modified: 2007-11-30 17:07 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2005-07-29 17:26:10 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Noriko Hosoi 2005-04-06 13:57:26 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5) Gecko/20041215 Firefox/1.0 Red Hat/1.0-12.EL4

Description of problem:
When no browser is up, trying to open an URL using htmlview brings up an unexpected page and it does not return.

Please note that RHEL3 htmlview returns immediately with this error:
    Error: No running window found.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. make sure no browser is launched
2. run 'htmlview -remote "openURL(http://www.redhat.com)"'


Actual Results:  1. it returns an error:
   /usr/bin/htmlview: line 75: [: -remote: binary operator expected
2. it brings up a default browser with the default initial page (note: not the page specified in the original command line "http://www.redhat.com")

Expected Results:  Either of these:
1) as being done on RHEL3 htmlview, return immediately with an appropriate error
2) display the specified URL

Additional info:
Comment 1 Noriko Hosoi 2005-04-06 14:04:51 EDT
rpm -q htmlview
Comment 2 Warren Togami 2005-04-25 03:28:01 EDT
Where did you hear about the "-remote" option of htmlview?  htmlview since
version 2.x contained the following.

# ignore legacy cruft
if [ "$1" == "--remote" ]; then
elif [ "$1" == "--local" ]; then

AFAIK "-remote" was never supported, and it would be passed to a browser and
that is the reason why you are seeing strange effects by using it.  --remote
would be ignored these days because X remote capable browsers handle it in their
own launch scripts automatically.

This bug should be closed NOTABUG, however if we have bad documentation
somewhere that mentions either -remote or --remote it should be corrected. 
Where did you hear about this option?
Comment 3 Nathan Kinder 2005-04-25 12:11:36 EDT
We are not referring to the "--remote" option of htmlview, but Mozilla's
"-remote" option.  Mozilla's "-remote" option allows you to connect to a running
browser process instead of starting a new one.  You can find out about it here:
Comment 4 Nathan Kinder 2005-04-25 14:39:27 EDT
I should also mention that the problem seems to be with the mimic_gnome_open
function of htmlview.  It seems to mess up the options that should just be
getting passed through to the browser.  This worked fine in htmlview 2.x, which
didn't have the mimic_gnome_open functionality.
Comment 5 Warren Togami 2005-04-25 17:30:16 EDT
What I'm saying is that passing -remote is totally not necessary because the
browser launcher itself is supposed to handle exactly that behavior
automatically.  That is not the case?
Comment 6 Warren Togami 2005-05-12 04:57:48 EDT
I added '-remote' as a parameter that FC4 htmlview will ignore.

htmlview is not meant to pass additional options to browsers.  One shouldn't
expect it to work either, because htmlview can be used to launch *any* browser
which is configured in Preferred Applications, which could be konqueror, opera
or even elinks.

Proposing this for RHEL4U2 mainly due to the fix in Bug #92335 which is more

1) htmlview changes since RHEL4 are trivial and obviously correct.
2) Fixes from Bug #92335 correct a clearly wrong and confusing behavior.
Comment 8 Noriko Hosoi 2005-07-29 17:22:47 EDT
We worked around not to use '-remote' in Directory Server 7.1 (on RHEL3 U4 and
We stop using the utility in the future version.
Thank you for your support.

To close this bug, to which value I should change the status?

Note You need to log in before you can comment on or make changes to this bug.