Bug 1540354 - Initramfs missing Intel VMD module when installed on Dell Precision 5820 with NVMe drive
Summary: Initramfs missing Intel VMD module when installed on Dell Precision 5820 with...
Keywords:
Status: CLOSED EOL
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: 27
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Anaconda Maintenance Team
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-01-30 20:37 UTC by artitj
Modified: 2018-11-30 23:46 UTC (History)
12 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-11-30 23:46:53 UTC
Type: Bug


Attachments (Terms of Use)
Log files from /var/log/anaconda (459.80 KB, application/x-gzip)
2018-01-31 15:41 UTC, artitj
no flags Details

Description artitj 2018-01-30 20:37:53 UTC
Description of problem:
A fresh Fedora 27 install from the Live USB fails to boot on a Dell Precision 5820 workstation with an NVMe boot drive, UEFI bios, SATA set to RAID, and Intel VMD enabled. Live USB has no trouble recognizing the drive and installing.

Version-Release number of selected component (if applicable):


How reproducible:
Every time


Steps to Reproduce:
1. Create a Live USB for Fedora 27 workstation using the Fedora Media Writer tool.
2. Boot from Live USB and proceed to install.
3. Select automatic partitioning, set a root password and create a new user.
4. Reboot the computer into the new Fedora install

Actual results:
Fedora boot splash will appear, after about 2 minutes, dracut-initqueue messages will begin to appear and the system will drop to a dracut rescue prompt.

Expected results:
Successful boot into display manager.

Additional info:
I solved the issue by booting off the live USB, mounting and then chrooting into the install on the NVMe drive, adding 'force_drivers+="vmd"' to /etc/dracut.conf.d/disk.conf and then running "dracut --force" to rebuild the initramfs with the vmd driver.

Computer is a Dell Precision 5820 with a Toshiba M.2 NVMe 512gb drive and an AMD WX2100 GPU.

Comment 1 artitj 2018-01-30 20:39:16 UTC
Sorry, just to add, in the dracut rescue prompt, the NVMe drive isn't detected, nor shows up in dmesg.

Comment 2 Jiri Konecny 2018-01-31 15:01:50 UTC
Hello,

Could you please provide us installation logs as plain text files. You can find them at /tmp/*.log in the installation environment or at /var/log/anaconda/*.log in the installed system.

Thank you.

Comment 3 artitj 2018-01-31 15:41:20 UTC
Created attachment 1389066 [details]
Log files from /var/log/anaconda

Comment 4 John Florian 2018-05-24 12:40:17 UTC
I ran into this exact scenario, same hardware but with a pair of the NVMe drives and Nvidia Quadro P2000.  Same solution worked for me although my real goal is to figure out why Workstation works (other than this bug) while KDE installs fail to boot after updates.

Comment 5 Ben Cotton 2018-11-27 13:31:05 UTC
This message is a reminder that Fedora 27 is nearing its end of life.
On 2018-Nov-30  Fedora will stop maintaining and issuing updates for
Fedora 27. It is Fedora's policy to close all bug reports from releases
that are no longer maintained. At that time this bug will be closed as
EOL if it remains open with a Fedora  'version' of '27'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version.

Thank you for reporting this issue and we are sorry that we were not 
able to fix it before Fedora 27 is end of life. If you would still like 
to see this bug fixed and are able to reproduce it against a later version 
of Fedora, you are encouraged  change the 'version' to a later Fedora 
version prior this bug is closed as described in the policy above.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events. Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

Comment 6 Ben Cotton 2018-11-30 23:46:53 UTC
Fedora 27 changed to end-of-life (EOL) status on 2018-11-30. Fedora 27 is
no longer maintained, which means that it will not receive any further
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of
Fedora please feel free to reopen this bug against that version. If you
are unable to reopen this bug, please file a new report against the
current release. If you experience problems, please add a comment to this
bug.

Thank you for reporting this bug and we are sorry it could not be fixed.


Note You need to log in before you can comment on or make changes to this bug.