Bug 1540427 - Web console version should keep consistent with master version
Summary: Web console version should keep consistent with master version
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Installer
Version: 3.9.0
Hardware: Unspecified
OS: Unspecified
medium
low
Target Milestone: ---
: 3.10.0
Assignee: Scott Dodson
QA Contact: Yanping Zhang
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-01-31 03:24 UTC by Yanping Zhang
Modified: 2018-07-30 19:09 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Control plane upgrade now ensures that the console version matches the version of other control plane components.
Clone Of:
Environment:
Last Closed: 2018-07-30 19:09:00 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2018:1816 None None None 2018-07-30 19:09:34 UTC

Comment 1 Samuel Padgett 2018-01-31 14:19:50 UTC
Did you set the `openshift_web_console_version` inventory var? It defaults to v3.9, so you might get a different version unless specify v3.9.0-0.33.0.

We're looking at changing how the prefix and version get set for the console in 3.10, but you need to set the variable for now, similar to metrics and logging.

Comment 2 Yanping Zhang 2018-02-01 08:34:45 UTC
I didn't set "openshift_web_console_version" in previous env installation. After I set "openshift_web_console_version = v3.9.0-0.33.0" in a new installation, the web console version is the defined "v3.9.0-0.33.0".
Now that the change is planed in 3.10, I'd like to change the target release to 3.10. Pls modify if it's not correct.

Comment 3 Samuel Padgett 2018-02-01 13:11:29 UTC
Changing priority to low since this is working as intended. It's reasonable to be able to set the version in one place for installs, however, and I know Scott has mentioned that as a goal. Scott, let me know if you have something tracking that already.

Comment 6 Yanping Zhang 2018-05-17 06:41:55 UTC
Tested with openshift-ansible-3.10.0-0.46.0.git.0.85c3afd.el7.noarch.rpm

Now install env without set `openshift_web_console_version` inventory var, master and web console pod will use image with v3.10 tag by default.
registry.reg-aws.openshift.com:443/openshift3/ose-control-plane             v3.10               35628f394eff        32 hours ago        634 MB
registry.reg-aws.openshift.com:443/openshift3/ose-web-console               v3.10               615eec2b9949        32 hours ago        318 MB
OpenShift Master:
    v3.10.0-0.46.0 
Kubernetes Master:
    v1.10.0+b81c8f8 
OpenShift Web Console:
    v3.10.0-0.46.0 
The master version and web console version are consistent now.

Comment 8 errata-xmlrpc 2018-07-30 19:09:00 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:1816


Note You need to log in before you can comment on or make changes to this bug.