This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 154056 - (maxdepth) xorg-x11 - xfs startup script generates multiple complaints by 'find'
xorg-x11 - xfs startup script generates multiple complaints by 'find'
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: xorg-x11 (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: X/OpenGL Maintenance List
David Lawrence
:
: 155337 (view as bug list)
Depends On:
Blocks: FC4Target
  Show dependency treegraph
 
Reported: 2005-04-06 17:22 EDT by Michal Jaegermann
Modified: 2007-11-30 17:11 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-04-13 20:27:04 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Michal Jaegermann 2005-04-06 17:22:00 EDT
Description of problem:

During a startup the following is spilled on a screen multiple times:

find: warning: you have specified the -maxdepth option after a non-option
argument -type, but options are not positional (-maxdepth affects tests
specified before it as well as those specified after it).  Please specify
options before other arguments.

Well, a fix is spelled out in this warning. :-)

Version-Release number of selected component (if applicable):
xorg-x11-xfs-6.8.2-19

How reproducible:
allways
Comment 1 Mike A. Harris 2005-04-06 18:42:42 EDT
Odd, this worked fine on my test system:


[root@laser TrueType]# find . -type f -maxdepth 1 -cnewer fonts.dir -not -name
'fonts.cache*'
[root@laser TrueType]# touch gbsn00lp.ttf
[root@laser TrueType]# find . -type f -maxdepth 1 -cnewer fonts.dir -not -name
'fonts.cache*'
./gbsn00lp.ttf



Can you cd into a font directory and try those commands?
Comment 2 Mike A. Harris 2005-04-06 19:18:29 EDT
Ok, thanks for reporting this by the way...

It turns out that this problem is just a "warning" in the newest
version of find.  My "find" is a bit older, and does not print this
warning.  The find manpage suggests to put "option" args at the front,
but does not indicate it is mandatory.  While it is only a warning,
the current "find" still executes properly and does the right thing.

Since it turns out this is just a bit of a cosmetic issue of an
ugly warning getting printed, it's not as severe as I had
initially been thinking.  (panicing actually)  ;o)

I've fixed it by moving "maxdepth 1" to the front of the args in
xorg-x11-6.8.2-20, however this new build probably will not get
put into test2, unless there are other major blockers found in
xorg which require a respin for.   ;o/

Nonetheless, I've fixed it and it will be in rawhide after test2.
I will also upload it on people.redhat.com once the new rpms are
built.

I suspect due to the alarmist nature of this bug, even though it
is only cosmetic, we will probably get numerous reports from test2
testers, so I am going to leave this bug open for now to use as
a master duplicate.

Thanks again Michal!
Comment 3 Mike A. Harris 2005-04-08 01:40:03 EDT
xorg-x11-6.8.2-20 successfully built, and will be in Fedora devel soon,
if it isn't there already.

While this bug is resolved now, I've decided to leave it open for a few
days to see how many dupes get reported.  I'm assuming this will get
reported a lot, and also assuming most people do not query closed bugs
in bugzilla before reporting, so once things die down, I'll close
it as fixed in "RAWHIDE".
Comment 4 Lars G 2005-04-08 11:11:50 EDT
new xorg-x11 from rawhide fixed this for me.
thanks!
Comment 5 Mike A. Harris 2005-04-19 06:19:11 EDT
*** Bug 155337 has been marked as a duplicate of this bug. ***
Comment 6 Dave Jones 2005-10-06 16:22:48 EDT
*** Bug 167394 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.