Bug 154058 - openoffice.org-1.9.89-3 - "Unable to locate theme engine"
openoffice.org-1.9.89-3 - "Unable to locate theme engine"
Product: Fedora
Classification: Fedora
Component: openoffice.org (Show other bugs)
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Caolan McNamara
Depends On:
  Show dependency treegraph
Reported: 2005-04-06 17:44 EDT by Michal Jaegermann
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version: 1.9.89-5
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2005-04-08 10:33:32 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Michal Jaegermann 2005-04-06 17:44:13 EDT
Description of problem:

Starting any of "component programs", like for example 'oowriter', from
openoffice.org-1.9.89-3 comes with the following warning:

(soffice.bin:3750): Gtk-WARNING **: Unable to locate theme engine in
module_path: "clearlooks",

'locate' shows only one "clearlooks".  Namely
from gtk2-engines package.  If that is what is serched for then 32-bit
soffice.bin cannot use 64-bit libraries but a dependency on
gtk2-engines.i386 does not seem to be present.

That warning may be not so benign as I observed right after that a progress
bar on OO splash to stop and 'oowriter' stuck and not starting.  OTOH
this does not seem to be easy to reproduce and it may be unrelated.

Version-Release number of selected component (if applicable):

How reproducible:
On every program startup.
Comment 1 Caolan McNamara 2005-04-07 08:01:34 EDT
I think adding a Requires: libbluecurve.so should do the right thing
Comment 2 Michal Jaegermann 2005-04-07 11:55:41 EDT
I do not know package relationships to that level, and what this library
really provides, but "libbluecurve.so" sounds awfully specific.  Is that really
a good idea? What if "artwork" will change for any reasons?

If "Unable to locate theme engine" is really only a warning, and there
are no good ways to avoid it, I think that I prefer a warning over a spurious
Comment 3 Caolan McNamara 2005-04-07 12:18:56 EDT
It's what the 1.1.X rpm does. From rh#153129# it seems the best way to force an
i386 dependancy on a package that is not directly linked to by the app is to
require directly a .so from that package. 1.1.X picked libbluecurve.so which
will pull in the gtk-engines from i386 so hopefully the same will work for 2.0
Comment 4 Michal Jaegermann 2005-04-07 20:26:35 EDT
Why then not simply 'Requires: gtk-engines' instead of forcing that in
a roundabout way which has a potential of failing in the future?
Comment 5 Caolan McNamara 2005-04-08 02:59:58 EDT
Because Requires: gtk-engines is useless for x86_64, it would be matched against
the 64bit gtk-engines. Which is what happened in rh#153129#
Comment 6 Caolan McNamara 2005-04-08 10:33:32 EDT
Hopefully good in 1.9.89-5

Note You need to log in before you can comment on or make changes to this bug.