Bug 154063 - korganizer crashes when viewing Outlook Calendar Message
korganizer crashes when viewing Outlook Calendar Message
Status: CLOSED UPSTREAM
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: kdepim (Show other bugs)
3.0
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Ngo Than
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-04-06 18:45 EDT by sa@tmt.ca.boeing.com
Modified: 2007-11-30 17:07 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-06-23 04:32:41 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Sample meeting.ics (1.43 KB, text/plain)
2005-05-23 09:50 EDT, sa@tmt.ca.boeing.com
no flags Details

  None (edit)
Description sa@tmt.ca.boeing.com 2005-04-06 18:45:43 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.4.3) Gecko/20050104 Red Hat/1.4.3-3.0.7

Description of problem:
User using kmail receives an Email message sent from Microsoft Outlook
that contains a calendar entry.  User clicks on meeting.ics icon to 
launch korganizer to view entry and when korganizer attempts to launch
it crashes with a SIGSEGV.

Note: There is a residual window (top-left of screen) from korgac which needs
to be manually closed, but otherwise the failure is immediate and quite
terminal.

Version-Release number of selected component (if applicable):
kdepim-3.1.3-3.3

How reproducible:
Always

Steps to Reproduce:
1.Email message received in kmail.
2.click on meeting.ics icon to launch korganizer.
3.immediate crash of korganizer

Additional info:

When launching korganizer, the following appear in the shell window:

DCOP aborting (delayed) call from 'anonymous-4669' to 'korganizer'


When korganizer crashes, the following traceback messages are in
the crash window:

(no debugging symbols found)...Using host libthread_db library "/lib64/tls/libthread_db.so.1".
(no debugging symbols found)...(no debugging symbols found)...(no debugging symbols found)...(no debugging symbols found)...(no debugging symbols found)...(no debugging symbols found)...(no debugging symbols found)...(no debugging symbols found)...(no debugging symbols found)...(no debugging symbols found)...(no debugging symbols found)...(no debugging symbols found)...(no debugging symbols found)...(no debugging symbols found)...(no debugging symbols found)...(no debugging symbols found)...(no debugging symbols found)...(no debugging symbols found)...(no debugging symbols found)...(no debugging symbols found)...(no debugging symbols found)...(no debugging symbols found)...(no debugging symbols found)...(no debugging symbols found)...(no debugging symbols found)...(no debugging symbols found)...[Thread debugging using libthread_db enabled]
[New Thread 182977574176 (LWP 4629)]
(no debugging symbols found)...(no debugging symbols found)...(no debugging symbols found)...(no debugging symbols found)...(no debugging symbols found)...(no debugging symbols found)...(no debugging symbols found)...(no debugging symbols found)...(no debugging symbols found)...(no debugging symbols found)...(no debugging symbols found)...(no debugging symbols found)...(no debugging symbols found)...(no debugging symbols found)...0x0000002a98564926 in waitpid () from /lib64/tls/libpthread.so.0
#0  0x0000002a98564926 in waitpid () from /lib64/tls/libpthread.so.0
#1  0x0000002a96f1488b in KCrash::defaultCrashHandler ()
   from /usr/lib64/libkdecore.so.4
#2  <signal handler called>
#3  0x0000002a96049b40 in icalproperty_string_to_enum ()
   from /usr/lib64/libkcal.so.2
#4  0x0000002a96054588 in icalvalue_new_enum () from /usr/lib64/libkcal.so.2
#5  0x0000002a9605475c in icalvalue_new_from_string_with_error ()
   from /usr/lib64/libkcal.so.2
#6  0x0000002a96054f1b in icalvalue_new_from_string ()
   from /usr/lib64/libkcal.so.2
#7  0x0000002a96049495 in icalparser_add_line () from /usr/lib64/libkcal.so.2
#8  0x0000002a960490c9 in icalparser_parse () from /usr/lib64/libkcal.so.2
#9  0x0000002a96049941 in icalparser_parse_string ()
   from /usr/lib64/libkcal.so.2
#10 0x0000002a96044869 in icalcomponent_new_from_string ()
   from /usr/lib64/libkcal.so.2
#11 0x0000002a96030c39 in KCal::ICalFormat::fromString ()
   from /usr/lib64/libkcal.so.2
#12 0x0000002a960309b1 in KCal::ICalFormat::load ()
   from /usr/lib64/libkcal.so.2
#13 0x0000002a9603c164 in KCal::FileStorage::load ()
   from /usr/lib64/libkcal.so.2
#14 0x0000002a9573fb8a in CalendarView::openCalendar ()
   from /usr/lib64/libkorganizer.so.1
#15 0x0000002a9576a71f in KOrganizer::openURL ()
   from /usr/lib64/libkorganizer.so.1
#16 0x0000002a957636da in KOrganizerApp::processCalendar ()
   from /usr/lib64/libkorganizer.so.1
#17 0x0000002a957632b7 in KOrganizerApp::newInstance ()
   from /usr/lib64/libkorganizer.so.1
#18 0x0000002a96f2c7e4 in KUniqueApplication::processDelayed ()
   from /usr/lib64/libkdecore.so.4
#19 0x0000002a96f2cae6 in KUniqueApplication::qt_invoke ()
   from /usr/lib64/libkdecore.so.4
#20 0x0000002a95762551 in KOrganizerApp::qt_invoke ()
   from /usr/lib64/libkorganizer.so.1
#21 0x0000002a979a09a3 in QObject::activate_signal ()
   from /usr/lib64/qt-3.1/lib/libqt-mt.so.3
#22 0x0000002a97c16ee2 in QSignal::signal ()
   from /usr/lib64/qt-3.1/lib/libqt-mt.so.3
#23 0x0000002a979b6564 in QSignal::activate ()
   from /usr/lib64/qt-3.1/lib/libqt-mt.so.3
#24 0x0000002a979bc2c8 in QSingleShotTimer::event ()
   from /usr/lib64/qt-3.1/lib/libqt-mt.so.3
#25 0x0000002a9794dea3 in QApplication::internalNotify ()
   from /usr/lib64/qt-3.1/lib/libqt-mt.so.3
#26 0x0000002a9794d8c1 in QApplication::notify ()
   from /usr/lib64/qt-3.1/lib/libqt-mt.so.3
#27 0x0000002a96eb3095 in KApplication::notify ()
   from /usr/lib64/libkdecore.so.4
#28 0x0000002a9792d8dd in QEventLoop::activateTimers ()
   from /usr/lib64/qt-3.1/lib/libqt-mt.so.3
#29 0x0000002a9790f31f in QEventLoop::processEvents ()
   from /usr/lib64/qt-3.1/lib/libqt-mt.so.3
#30 0x0000002a9795f26f in QEventLoop::enterLoop ()
   from /usr/lib64/qt-3.1/lib/libqt-mt.so.3
#31 0x0000002a9795f132 in QEventLoop::exec ()
   from /usr/lib64/qt-3.1/lib/libqt-mt.so.3
#32 0x0000002a9794e025 in QApplication::exec ()
   from /usr/lib64/qt-3.1/lib/libqt-mt.so.3
#33 0x0000002a9573bb8d in main () from /usr/lib64/libkorganizer.so.1
#34 0x0000002a98e0c1ae in __libc_start_main () from /lib64/tls/libc.so.6
#35 0x00000000004007aa in ?? ()
#36 0x0000007fbfffb068 in ?? ()
#37 0x0000000000000000 in ?? ()
Comment 1 Ngo Than 2005-04-21 05:29:19 EDT
could you please try kdepim-3.1.3-3.4 on ftp://people.redhat.com/than/rhel3.
Does it fix this problem for you?
Comment 2 sa@tmt.ca.boeing.com 2005-04-21 13:36:18 EDT
Sadly it did not fix the problem.  In the launching (shell) window I get:

QMetaObject::findSignal:KOTodoListView: Conflict with
KListView::doubleClicked(QListViewItem*,const
QPoint&,int)QMetaObject::findSignal:KOAgendaView: Conflict with
KOEventView::editEventSignal(Event*)
QMetaObject::findSignal:KOAgendaView: Conflict with
KOEventView::showEventSignal(Event*)
QMetaObject::findSignal:KOAgendaView: Conflict with
KOEventView::deleteEventSignal(Event*)
QMetaObject::findSignal:KOAgendaView: Conflict with
KOEventView::editEventSignal(Event*)
QMetaObject::findSignal:KOAgendaView: Conflict with
KOEventView::showEventSignal(Event*)
QMetaObject::findSignal:KOAgendaView: Conflict with
KOEventView::deleteEventSignal(Event*)
QMetaObject::findSignal:KOAgendaView: Conflict with
KOEventView::editEventSignal(Event*)
QMetaObject::findSignal:KOAgendaView: Conflict with
KOEventView::editEventSignal(Event*)
QMetaObject::findSignal:KOAgendaView: Conflict with
KOEventView::showEventSignal(Event*)
QMetaObject::findSignal:KOAgendaView: Conflict with
KOEventView::showEventSignal(Event*)
QMetaObject::findSignal:KOAgendaView: Conflict with
KOEventView::deleteEventSignal(Event*)
QMetaObject::findSignal:KOAgendaView: Conflict with
KOEventView::deleteEventSignal(Event*)
QMetaObject::findSignal:KOAgendaView: Conflict with
KOEventView::newEventSignal(QDateTime)
QMetaObject::findSignal:KOAgendaView: Conflict with
KOEventView::newEventSignal(QDateTime,QDateTime)
QMetaObject::findSignal:KOAgendaView: Conflict with
KOEventView::editEventSignal(Event*)
QMetaObject::findSignal:KOAgendaView: Conflict with
KOEventView::showEventSignal(Event*)
QMetaObject::findSignal:KOAgendaView: Conflict with
KOEventView::deleteEventSignal(Event*)
DCOP aborting (delayed) call from 'anonymous-8232' to 'korganizer'

and the backtrace for korganizer reads as thus:

(no debugging symbols found)...Using host libthread_db library
"/lib64/tls/libthread_db.so.1".
(no debugging symbols found)...(no debugging symbols found)...(no debugging
symbols found)...(no debugging symbols found)...(no debugging symbols
found)...(no debugging symbols found)...(no debugging symbols found)...(no
debugging symbols found)...(no debugging symbols found)...(no debugging symbols
found)...(no debugging symbols found)...(no debugging symbols found)...(no
debugging symbols found)...(no debugging symbols found)...(no debugging symbols
found)...(no debugging symbols found)...(no debugging symbols found)...(no
debugging symbols found)...(no debugging symbols found)...(no debugging symbols
found)...(no debugging symbols found)...(no debugging symbols found)...(no
debugging symbols found)...(no debugging symbols found)...(no debugging symbols
found)...(no debugging symbols found)...[Thread debugging using libthread_db
enabled]
[New Thread 182977570080 (LWP 8233)]
(no debugging symbols found)...(no debugging symbols found)...(no debugging
symbols found)...(no debugging symbols found)...(no debugging symbols
found)...(no debugging symbols found)...(no debugging symbols found)...(no
debugging symbols found)...(no debugging symbols found)...(no debugging symbols
found)...(no debugging symbols found)...(no debugging symbols found)...(no
debugging symbols found)...(no debugging symbols found)...0x0000002a98563926 in
waitpid () from /lib64/tls/libpthread.so.0
#0  0x0000002a98563926 in waitpid () from /lib64/tls/libpthread.so.0
#1  0x0000002a96f1388b in KCrash::defaultCrashHandler ()
   from /usr/lib64/libkdecore.so.4
#2  <signal handler called>
#3  0x0000002a96048b00 in icalproperty_string_to_enum ()
   from /usr/lib64/libkcal.so.2
#4  0x0000002a96053548 in icalvalue_new_enum () from /usr/lib64/libkcal.so.2
#5  0x0000002a9605371c in icalvalue_new_from_string_with_error ()
   from /usr/lib64/libkcal.so.2
#6  0x0000002a96053edb in icalvalue_new_from_string ()
   from /usr/lib64/libkcal.so.2
#7  0x0000002a96048455 in icalparser_add_line () from /usr/lib64/libkcal.so.2
#8  0x0000002a96048089 in icalparser_parse () from /usr/lib64/libkcal.so.2
#9  0x0000002a96048901 in icalparser_parse_string ()
   from /usr/lib64/libkcal.so.2
#10 0x0000002a96043829 in icalcomponent_new_from_string ()
   from /usr/lib64/libkcal.so.2
#11 0x0000002a9602fbf9 in KCal::ICalFormat::fromString ()
   from /usr/lib64/libkcal.so.2
#12 0x0000002a9602f971 in KCal::ICalFormat::load ()
   from /usr/lib64/libkcal.so.2
#13 0x0000002a9603b124 in KCal::FileStorage::load ()
   from /usr/lib64/libkcal.so.2
#14 0x0000002a9573fb4a in CalendarView::openCalendar ()
   from /usr/lib64/libkorganizer.so.1
#15 0x0000002a9576a6df in KOrganizer::openURL ()
   from /usr/lib64/libkorganizer.so.1
#16 0x0000002a9576369a in KOrganizerApp::processCalendar ()
   from /usr/lib64/libkorganizer.so.1
#17 0x0000002a95763277 in KOrganizerApp::newInstance ()
   from /usr/lib64/libkorganizer.so.1
#18 0x0000002a96f2b7e4 in KUniqueApplication::processDelayed ()
   from /usr/lib64/libkdecore.so.4
#19 0x0000002a96f2bae6 in KUniqueApplication::qt_invoke ()
   from /usr/lib64/libkdecore.so.4
#20 0x0000002a95762511 in KOrganizerApp::qt_invoke ()
   from /usr/lib64/libkorganizer.so.1
#21 0x0000002a9799f9a3 in QObject::activate_signal ()
   from /usr/lib64/qt-3.1/lib/libqt-mt.so.3
#22 0x0000002a97c15ee2 in QSignal::signal ()
   from /usr/lib64/qt-3.1/lib/libqt-mt.so.3
#23 0x0000002a979b5564 in QSignal::activate ()
   from /usr/lib64/qt-3.1/lib/libqt-mt.so.3
#24 0x0000002a979bb2c8 in QSingleShotTimer::event ()
   from /usr/lib64/qt-3.1/lib/libqt-mt.so.3
#25 0x0000002a9794cea3 in QApplication::internalNotify ()
   from /usr/lib64/qt-3.1/lib/libqt-mt.so.3
#26 0x0000002a9794c8c1 in QApplication::notify ()
   from /usr/lib64/qt-3.1/lib/libqt-mt.so.3
#27 0x0000002a96eb2095 in KApplication::notify ()
   from /usr/lib64/libkdecore.so.4
#28 0x0000002a9792c8dd in QEventLoop::activateTimers ()
   from /usr/lib64/qt-3.1/lib/libqt-mt.so.3
#29 0x0000002a9790e31f in QEventLoop::processEvents ()
   from /usr/lib64/qt-3.1/lib/libqt-mt.so.3
#30 0x0000002a9795e26f in QEventLoop::enterLoop ()
   from /usr/lib64/qt-3.1/lib/libqt-mt.so.3
#31 0x0000002a9795e132 in QEventLoop::exec ()
   from /usr/lib64/qt-3.1/lib/libqt-mt.so.3
#32 0x0000002a9794d025 in QApplication::exec ()
   from /usr/lib64/qt-3.1/lib/libqt-mt.so.3
#33 0x0000002a9573bb4d in main () from /usr/lib64/libkorganizer.so.1
#34 0x0000002a98e0b1ae in __libc_start_main () from /lib64/tls/libc.so.6
#35 0x000000000040077a in ?? ()
#36 0x0000007fbfffb408 in ?? ()
#37 0x0000000000000000 in ?? ()
Comment 3 sa@tmt.ca.boeing.com 2005-05-19 16:29:58 EDT
Hi!  Any more thoughts on this issue?  We have not yet
an opportunity to upgrade to RHEL 4, but was curious if
you've had an opportunity to test to see if this problem
exists in RHEL 4 as well as RHEL 3?
Comment 4 Ngo Than 2005-05-23 06:07:04 EDT
Could you please attach the meeting.ics or similar to reproduce this problem. I
will help to debug this issue. Thanks


I will upload new kdepim-3.1.3-3.5 today on people.redhat.com. It will hopefully
fix this bug. 
Comment 5 sa@tmt.ca.boeing.com 2005-05-23 09:50:51 EDT
Created attachment 114713 [details]
Sample meeting.ics
Comment 6 Ngo Than 2005-05-24 10:12:43 EDT
I can reproduce this problem now. My previous patch still does not fix this issue.
I'm still debugging this problem.
Comment 7 Ngo Than 2005-05-25 11:13:20 EDT
i have already uploaded the new kdepim-3.1.3-3.5 on people.redhat.com.
This problem is now fixed in this version. Could you please verify it?

Thanks
Comment 8 sa@tmt.ca.boeing.com 2005-06-16 19:05:24 EDT
Sorry for the delay in responding to your Email.

I tried to download kdepim-3.1.3-3.5 on Red Hat Network, but am
unable to locate it.  What URL should I be using to acquire this
release and see if it'll fix our problem?

Thanks!
Comment 9 Ngo Than 2005-06-17 04:31:29 EDT
there's only available on ftp://people.redhat.com/than/rhel3 ATM.

could you please verify it. It works for me. Thanks
Comment 10 sa@tmt.ca.boeing.com 2005-06-22 18:31:39 EDT
Hi!  I just loaded kdepim-3.1.3-3.5 and kmail now works like a charm!
Calendar message received, viewable and no crashes...hooray!

Thanks for fix!
Comment 11 Ngo Than 2005-06-23 04:32:41 EDT
The fix will be included if we build it for RHEL3 update. Thanks for the testing. 

Note You need to log in before you can comment on or make changes to this bug.