Bug 1540669 - Do lock conflict check correctly for wait-list
Summary: Do lock conflict check correctly for wait-list
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: disperse
Version: mainline
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: bugs@gluster.org
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks: 1540882 1540896 1540908
TreeView+ depends on / blocked
 
Reported: 2018-01-31 17:02 UTC by Pranith Kumar K
Modified: 2018-06-20 17:58 UTC (History)
1 user (show)

Fixed In Version: glusterfs-v4.1.0
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1540882 (view as bug list)
Environment:
Last Closed: 2018-06-20 17:58:44 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Pranith Kumar K 2018-01-31 17:02:32 UTC
Description of problem:
    Problem:
    ec_link_has_lock_conflict() is traversing over only owner_list
    but the function is also getting called with wait_list.
    
    Fix:
    Modify ec_link_has_lock_conflict() to traverse lists correctly.
    Updated the callers to reflect the changes.


Version-Release number of selected component (if applicable):


How reproducible:
Found while code-reading

Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 Worker Ant 2018-01-31 17:11:00 UTC
REVIEW: https://review.gluster.org/19415 (cluster/ec: Do lock conflict check correctly for wait-list) posted (#1) for review on master by Pranith Kumar Karampuri

Comment 2 Worker Ant 2018-02-01 09:07:51 UTC
COMMIT: https://review.gluster.org/19415 committed in master by "Xavier Hernandez" <jahernan@redhat.com> with a commit message- cluster/ec: Do lock conflict check correctly for wait-list

Problem:
ec_link_has_lock_conflict() is traversing over only owner_list
but the function is also getting called with wait_list.

Fix:
Modify ec_link_has_lock_conflict() to traverse lists correctly.
Updated the callers to reflect the changes.

BUG: 1540669
Change-Id: Ibd7ea10f4498e7c2761f9a6faac6d5cb7d750c91
Signed-off-by: Pranith Kumar K <pkarampu@redhat.com>

Comment 3 Shyamsundar 2018-06-20 17:58:44 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-v4.1.0, please open a new bug report.

glusterfs-v4.1.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://lists.gluster.org/pipermail/announce/2018-June/000102.html
[2] https://www.gluster.org/pipermail/gluster-users/


Note You need to log in before you can comment on or make changes to this bug.