Bug 154072 - Clear Recent documents button does not clear the recent documents
Clear Recent documents button does not clear the recent documents
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: gamin (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Daniel Veillard
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-04-06 20:45 EDT by Ivan Gyurdiev
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-08-22 13:03:54 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ivan Gyurdiev 2005-04-06 20:45:04 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.6) Gecko/20050328 Firefox/1.0.2 Fedora/1.0.2-3

Description of problem:
This is rawhide. 

The "Clear Recent documents" button has not worked for me reliably since
it was first introduced (a long time ago). 
Sometimes it clears the documents, sometimes it does not. 
Nowdays it just seems to never work. gam_server is running.

gamin-0.0.26-1

Ask questions for more details - not sure what to provide.

I would like to help debug the issue, and release FC4 without this ancient bug.


Version-Release number of selected component (if applicable):
gnome-panel-2.10.1-1

How reproducible:
Always

Steps to Reproduce:
1. Click the "Clear Recent documents button"
 

Actual Results:  The recent documents are not cleared.

Expected Results:  The recent documents should be cleared.

Additional info:
Comment 1 Colin Charles 2005-04-07 01:45:46 EDT
Tried on rawhide, gamin-0.0.26-1.i386 and gnome-panel-2.10.0-3.i386 and it
worked. So there could be some form of regression if it doesn't work with
gnome-panel-2.10.1-1 (what the reporter has installed)
Comment 2 Ivan Gyurdiev 2005-04-07 02:04:42 EDT
Well, now it's working for me too..
but that's my point exactly. Sometimes it works, and then other times
it doesn't. Do you have any suggestions for how to attempt to reproduce the
problem, or what data to look for when it's not working?

Comment 3 Mark McLoughlin 2005-04-07 07:47:13 EDT
Most likely a gamin issue.

Is this an NFS homedir by any chance?

You could try and pull debug logs from gamin according to:

  http://www.gnome.org/~veillard/gamin/debug.html
Comment 4 Ivan Gyurdiev 2005-04-08 05:17:22 EDT
No NFS. 

Alright, here's what happens - those are documents I clicked on from mozilla,
and opened in gedit. Not sure what that means - they were downloaded in ~/tmp,
and are no longer there, probably...

So I can keep clicking on Clear Recent Documents, and it has no effect of any
kind. Then when I open a local file, all the documents in question disappear,
and I can clear the local fine just fine.
Comment 5 Ivan Gyurdiev 2005-04-08 05:19:53 EDT
...but on the other hand, creating a file, opening it, then deleting it,
and trying to clear recent documents works just fine. I'm not sure what the
problem is. 

Note You need to log in before you can comment on or make changes to this bug.