Bug 154083 - Use real mount rather than busybox mount
Use real mount rather than busybox mount
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: busybox (Show other bugs)
4.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ivana Varekova
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-04-07 01:24 EDT by Mike MacCana
Modified: 2007-11-30 17:07 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-03-28 08:53:40 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mike MacCana 2005-04-07 01:24:40 EDT
Description of problem:
Busybox mount can't mount devices using labels. This is a headache for most
users - it's inconsistent with the normal command, and seems to be the basis of
anaconda not mounting all the correct devices during rescues.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.linux rescue
  
Actual results:
Missing devices requiring manual mounting.
A mount command that doesn't consistently with the rest of RHEL (mount, fsck,
/etc/fstab, etc).


Expected results:
mount should work normally. Using the real mount command seems preferable to
adding label support to busybox (see
http://www.busybox.net/lists/busybox/2003-November/009906.html), especially now
we don't have to worry about floppy rescues.

Additional info:
Comment 4 Ivana Varekova 2007-03-28 08:53:40 EDT
This is feature request and this feature is not add in upstream version. It
should be added to upstream/devel branch to be tested at first. So I'm closing
this bug.

Note You need to log in before you can comment on or make changes to this bug.