Bug 1540840 - ansible service broker still using ocp3.7 images after upgrade to ocp3.9
Summary: ansible service broker still using ocp3.7 images after upgrade to ocp3.9
Status: CLOSED CURRENTRELEASE
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Upgrade
Version: 3.9.0
Hardware: Unspecified
OS: Unspecified
urgent
urgent
Target Milestone: ---
: 3.9.0
Assignee: Fabian von Feilitzsch
QA Contact: Jian Zhang
URL:
Whiteboard:
Keywords:
Depends On: 1547803
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-02-01 06:22 UTC by Zhang Cheng
Modified: 2018-03-27 09:46 UTC (History)
11 users (show)

(edit)
undefined
Clone Of:
(edit)
Last Closed: 2018-03-16 16:56:30 UTC


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2018:0489 normal SHIPPED_LIVE Red Hat OpenShift Container Platform 3.9 RPM Release Advisory 2018-03-28 18:06:38 UTC

Comment 1 Ben Parees 2018-02-01 22:53:30 UTC
Not sure about the service catalog+ASB, but for the TSB it seems like the apiserver-template.yaml needs to be reapplied w/ a new $IMAGE parameter value.

Comment 2 Wenjing Zheng 2018-02-02 02:16:35 UTC
(In reply to Ben Parees from comment #1)
> Not sure about the service catalog+ASB, but for the TSB it seems like the
> apiserver-template.yaml needs to be reapplied w/ a new $IMAGE parameter
> value.

I reported a bug [1] about TSB upgrade issue, it still use ose:v3.7 after upgrade, but the apiserver-template.yaml for installer has been updated to use new image :https://github.com/openshift/openshift-ansible/blob/master/roles/template_service_broker/files/apiserver-template.yaml#L7 and it is also using new image in fresh install.

[1] https://bugzilla.redhat.com/show_bug.cgi?id=1540521

Comment 3 Ben Parees 2018-02-02 04:09:39 UTC
> but the apiserver-template.yaml for installer has been updated to use new image 

well it shouldn't be using latest, but i assume the IMAGE parameter is getting substituted properly on a fresh install which is why it's ok for you on a new install.  Anyway we'll chase the TSB side of this in your bug 1540521.

i suggest you open separate bugs for the SC and ASB as well.  Scott may be the coordinator but each component team probably needs to be involved.

Comment 4 Zhang Cheng 2018-02-02 05:33:36 UTC
I'm changing title to "ansible service broker still using ocp3.7 images after upgrade to ocp3.9" for separate issues.
And, I hope to trace asb side in here. And submitted another bug 1541247 to trace service-catalog side. Thanks.

Comment 5 Scott Dodson 2018-02-02 16:24:18 UTC
To fix this we need to

1) Land Vadim's changes so that the image tag for service catalog, tsb, etc matches the master image tag

2) Audit service catalog, tsb, asb roles to ensure that re-running their install tasks use `oc process | oc apply` to re-apply the new templates.

Comment 6 Ben Parees 2018-02-02 16:25:44 UTC
3) make sure we are actually rerunning their install tasks on upgrade

Comment 7 Michael Gugino 2018-02-22 20:15:59 UTC
PR Created: https://github.com/openshift/openshift-ansible/pull/7251

Comment 9 Jian Zhang 2018-03-05 03:03:27 UTC
The ASB switch depends on the service catalog, changed the status to "MODIFIED" since have a blocking bug 1547803. Not ready for a test.

Comment 10 Jian Zhang 2018-03-07 04:33:03 UTC
The openshift-ansible version:
openshift-ansible-3.9.3-1.git.0.e166207.el7.noarch

The tag of the ASB image is still the "v3.7" after an upgrade.

Verify failed.

Comment 11 Fabian von Feilitzsch 2018-03-08 20:24:11 UTC
It looks like this change has not yet made it to a tag:
https://github.com/openshift/openshift-ansible/pull/7411

Comment 12 Fabian von Feilitzsch 2018-03-08 20:26:04 UTC
I ran it through a few times locally with the latest release-3.9 and was unable to reproduce this bug, I think once the above PR is tagged in we'll be fine.


Note You need to log in before you can comment on or make changes to this bug.