Bug 1540921 - [RFE] Deprecate and remove support for Conroe and Penryn CPUs
Summary: [RFE] Deprecate and remove support for Conroe and Penryn CPUs
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine
Version: unspecified
Hardware: Unspecified
OS: Unspecified
low
medium
Target Milestone: ovirt-4.3.0
: ---
Assignee: Steven Rosenberg
QA Contact: Nisim Simsolo
URL:
Whiteboard:
Depends On: 1623259 1623266 1637462
Blocks: 1649817
TreeView+ depends on / blocked
 
Reported: 2018-02-01 10:38 UTC by Michal Skrivanek
Modified: 2019-05-08 12:37 UTC (History)
10 users (show)

Fixed In Version: ovirt-engine-4.3.0_rc
Doc Type: Deprecated Functionality
Doc Text:
Conroe and Penryn CPU types are no longer supported. They will not appear as options for Compatibility Version 4.3, and a warning is displayed for older versions.
Clone Of:
: 1649817 (view as bug list)
Environment:
Last Closed: 2019-05-08 12:36:59 UTC
oVirt Team: Virt
Target Upstream Version:
mavital: testing_plan_complete-


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2019:1085 0 None None None 2019-05-08 12:37:22 UTC
oVirt gerrit 94876 0 master MERGED core: Deprecate CPU Types 2020-06-17 04:29:26 UTC
oVirt gerrit 95310 0 master MERGED core: Deprecated the IBRS CPU Types 2020-06-17 04:29:26 UTC
oVirt gerrit 95498 0 master MERGED core: Deprecated the IBRS CPU Types 2020-06-17 04:29:26 UTC
oVirt gerrit 95773 0 master MERGED core: Reformat ServerCPUList value to ease review 2020-06-17 04:29:26 UTC

Description Michal Skrivanek 2018-02-01 10:38:20 UTC
It's time to stop supporting ancient CPUs, Intel has no plan to patch them for Spectre vulnerabilities

Thoughts on how best to do that?

Comment 4 Michal Skrivanek 2018-08-22 11:59:08 UTC
+all IBRS CPU types, they're obsoleted by SSBD

Comment 5 Steven Rosenberg 2018-11-07 12:22:39 UTC
We agree to remove the IBRS CPU Types and preserve the IBRS SSBD CPU types. For the setup, we need to change the Cluster CPU Types set to IBRS to a supported CPU. Please confirm that the correct approach is to upgrade the IBRS CPU Types to their corresponding IBRS SSBD CPU Types.

Comment 6 Steven Rosenberg 2018-11-08 09:48:12 UTC
It seems we also want to deprecate AMD EPYC / AMD EPYC IBPB
Please clarify. We have three AMD EPYCs:

7:AMD EPYC:svm,nx,model_EPYC:EPYC:x86_64; 8:AMD EPYC IBPB:svm,nx,ibpb,model_EPYC:EPYC,+ibpb:x86_64; 9:AMD EPYC IBPB:svm,nx,ibpb,ssbd,model_EPYC:EPYC,+ibpb,+virt-ssbd:x86_64;

Levels 7 - 9. 

There seems to be two AMD EPYC IBPB entries 8-9. Do we want to deprecate 8 and 9 and default to 7 during the setup for 4.3?

Comment 7 Steven Rosenberg 2018-11-08 11:52:01 UTC
Note: The Level 9 entry for AMD was incorrect, we changed the cpu type name to "AMD EPYC IBPB SSBD" and deprecated level 8 for AMD as per the Intel CPU Type changes.

Comment 8 Nisim Simsolo 2018-12-06 12:26:54 UTC
Verified: 
ovirt-engine-4.3.0-0.2.master.20181203100035.git0ee44c1.el7
qemu-kvm-ev-2.12.0-18.el7_6.1.1.x86_64
vdsm-4.30.3-71.git7d6039c.el7.x86_64
libvirt-client-4.5.0-10.el7.x86_64

Verification scenario: 
1. Change DC and Cluster compatibility version to 4.2
2. Verify Intel Conroe and Penryn can be selected.
   Verify AMD Opteron G1, G2 and G3 can be selected.
   Verify a question mark icon appears on the cluster stating that:
   "Upgrade Cluster Compatibility level 
   Warning: The CPU type 'Intel Conroe Family' is not being supported in 
   version 4.3 and later."
   Verify this warning icon and message appear also for Intel Penryn, AMD Opteron G1/G2/G3
3. Change DC and Cluster compatibility level to 4.3
   Verify Intel Conroe/Penryn family and AMD Opteron G1/G2/G3 are not listed in cluster dialog -> General -> CPU type dropbox.
   Verify AMD EPYC and AMD EPYC IBPB SSBD added to the dropbox.
   Verify warning icon removed from cluster.
4. Install host on 4.2 cluster with Intel Conroe family configured, create VM and run it.
5. Change Cluster compatibility level to 4.3
   Verify Cluster CPU type changed to Intel Nehalem family. 
   Verify Host is still in UP atatus and VM continues to run.

Comment 10 errata-xmlrpc 2019-05-08 12:36:59 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2019:1085


Note You need to log in before you can comment on or make changes to this bug.