Bug 154093 - Bad links in kdelibs
Bad links in kdelibs
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kdelibs (Show other bugs)
rawhide
All Linux
medium Severity low
: ---
: ---
Assigned To: Ngo Than
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-04-07 04:11 EDT by Ignacio Vazquez-Abrams
Modified: 2007-11-30 17:11 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 09:26:12 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ignacio Vazquez-Abrams 2005-04-07 04:11:26 EDT
The links in /usr/shar/icons/crystalsvg/*/apps in the kdelibs package point to
files in the kdebase package.
Comment 1 Ignacio Vazquez-Abrams 2005-04-07 04:20:57 EDT
Additionally there are some links in /usr/share/icons/default.kde/*/apps that
are misplaced, as well as /usr/share/icons/hicolor/48x48/apps/redhat-office.png
that doesn't go anywhere.
Comment 2 Niko Mirthes 2005-12-18 17:05:28 EST
I'd like to see the redhat- and related symlinks removed altogether. They tend
to break kde icon themes. If you can't accomplish this within the Bluecurve icon
theme, don't use a symlink hack to fix it.

This is done here, in the kdelibs.spec:

%if %{redhatify}
	pushd $RPM_BUILD_ROOT%{_datadir}/icons/crystalsvg
	for s in 16x16 22x22 32x32 48x48 64x64 128x128; do
		pushd $s/apps/ || continue
		# package icons
		ln -sf package_wordprocessing.png redhat-office.png
		ln -sf package_network.png redhat-internet.png
		ln -sf package_applications.png redhat-accessories.png
		ln -sf package_graphics.png redhat-graphics.png
		ln -sf package_games.png redhat-games.png
		ln -sf multimedia.png redhat-sound_video.png
		ln -sf package_settings.png redhat-preferences.png
		ln -sf package_development.png redhat-programming.png
		ln -sf ../filesystems/server.png redhat-network-server.png
		ln -sf ../filesystems/server.png redhat-server_settings.png
		ln -sf package_utilities.png redhat-system_tools.png
		ln -sf package_system.png redhat-system_settings.png
		ln -sf package_utilities.png redhat-tools.png
		# app icons
		ln -sf kmail.png redhat-email.png
		ln -sf konqueror.png redhat-web-browser.png
		ln -sf kfm.png redhat-filemanager.png
		ln -sf kfm_home.png redhat-home.png
		ln -sf kviewshell.png redhat-logviewer.png
		# system settings
		ln -sf multimedia.png system-config-soundcard.png
		popd
	done
	popd
	rm -f $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/index.theme
	rm -f $RPM_BUILD_ROOT/etc/xdg/menus/applications.menu
	install -m 644 %{SOURCE3} $RPM_BUILD_ROOT/etc/xdg/menus/
   pushd $RPM_BUILD_ROOT/etc/xdg/menus/
   ln -s applications-merged kde-applications-merged
   popd
	echo "OnlyShowIn=KDE;" >>
$RPM_BUILD_ROOT%{_datadir}/applications/kde/kresources.desktop
%endif

A similar hack is done in /usr/share/hicolor, creating symlinks to icons from
gnome-icon-theme that shouldn't be there anyway. Doing this violates the Icon
Theme Specification and just validates gnome-icon-theme's upstream hack of a
similar nature.
Comment 3 Rex Dieter 2005-12-19 15:40:27 EST
Niko, amen brother.

Is the redhat-artwork/gnome-icon-theme maintainer (johnp, CC'd) even aware of
this bug?  IMNSHO, The (sym)links to these icons should live in the symlinks'
target pkg, not here.
Comment 4 Niko Mirthes 2005-12-19 17:27:27 EST
I intend to file bugs against both gnome-icon-theme and crystalsvg in the hope
of evicting inappropriate icons from the hicolor theme altogether. The upstream
gnome-icon-theme maintainer (Rodney Dawes) is receptive to this. I haven't
approached any KDE folks about it just yet.
Comment 5 Rex Dieter 2006-01-19 08:26:18 EST
Niko, Re: comment #4, did you ever file those bugs?  If so, what are the bz 
#'s? 
Comment 6 Rex Dieter 2006-01-19 09:18:42 EST
FYI, these symlinks originated with bug #121929 
Comment 7 Niko Mirthes 2006-01-19 12:14:45 EST
Rex, no actually I haven't filed in the respective bugzillas. I've spoken with  
the upstream maintainer for gnome-icon-theme, and he's indicated that g-i-t  
will no longer be placing icons in hicolor in the near future (the changes are  
in g-i-t CVS, and changed as of 2.13.5). As for KDE, I've decided to hold off  
and see what the plan is for KDE 4. Reporting this now to bugs.kde.org would  
likely result in the bug not getting much attention as people change focus to  
kde trunk. It's unlikely anyone's going to see this as important in the KDE  
3.x.x timeframe. That's not to say I'd be happy with things remaining as they  
are symlink-wise for fedora's KDE packages. The problem described in bug 
#121929 seems to be a direct result of g-i-t placing icons in hicolor, and 
crystalsvg's wrongly inheriting hicolor (see Inherits=hicolor in 
crystalsvg's index.theme). 
Comment 8 Rex Dieter 2006-01-19 12:35:02 EST
How is crystalsvg's Inherits=hicolor wrong?  AFAICT from reading the fdo icon
spec, it may be superfluous, since *all* icon themes implicitly inherit from
hicolor.
Comment 9 Niko Mirthes 2006-01-19 13:13:44 EST
From what I've been told, since crystalsvg is the default KDE theme, it 
shouldn't Inherit anything. The icon theme implementation must always include 
hicolor as the last theme to pull icons from anyway (it's implicit). Since 
hicolor doesn't include icons by default, inheriting from it is broken. KDE 
should probably just do what GNOME is doing in 2.14 for the "default" icon 
theme, and use a setting for a fallback theme, so that it looks in the default 
fallback just before hicolor. I've had the Net/FallbackIconTheme (sp?) hint 
suggested to me, though apparently it's a new development. I'd have to do some 
research to discover the particulars. 
Comment 10 Niko Mirthes 2006-02-11 14:35:00 EST
Has anyone noticed many of the symlinks created as described in Comment #2 are 
now broken? It seems many of the app icons that were symlinked have now been 
moved to the hicolor directory. 
Comment 11 Ngo Than 2006-02-21 09:26:12 EST
i added the symlinks in redhat-artwork-0.239-2. The crystal icon theme should 
work fine now. Thanks for your report. 

Note You need to log in before you can comment on or make changes to this bug.