Bug 154106 - dhcp not possible when booting inside vmware
dhcp not possible when booting inside vmware
Status: CLOSED DUPLICATE of bug 100527
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: kernel (Show other bugs)
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: John W. Linville
Brian Brock
Depends On:
  Show dependency treegraph
Reported: 2005-04-07 08:09 EDT by Joerg Hinz
Modified: 2007-11-30 17:07 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2005-04-13 11:36:46 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
Patch to fix dhcp-problems with vmware (586 bytes, patch)
2005-04-07 13:01 EDT, Joerg Hinz
no flags Details | Diff

  None (edit)
Description Joerg Hinz 2005-04-07 08:09:42 EDT
From Bugzilla Helper:
User-Agent: Opera/8.0 (Windows NT 5.0; U; en)

Description of problem:
When using RHEL3 inside vmware and eth0 is set to dhcp, the check_link_down()-
function inside /etc/sysconfig/network-scripts/network-funktions fails to detect 
the link and always returns "link down" which causes to fail getting the dhcp-

Starting dhclient manually works, so the problem is script-specific.

A quick (but dirty) workaround is making check_link_down-function in /etc/
sysconfig/network-scripts/network-funktions always return 1:

check_link_down ()
    return 1

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. Install RHEL inside vmware (bridged networking (pcnet32-driver)
2. Set eth0 to dhcp
3. Boot the System
4. The problem is reproducable every time you call /etc/init.d/networking start

Actual Results:  The init-script always says "failed; no link present. Check cable?" when trying 
to initialize eth0.

Expected Results:  The link should be properly set up.

Additional info:
Comment 1 Joerg Hinz 2005-04-07 09:58:30 EDT
This Patch fixes the problem:

--- /etc/sysconfig/network-scripts/network-functions.RHEL3      2005-04-07 15:
50:44.000000000 +0200
+++ /etc/sysconfig/network-scripts/network-functions    2005-04-07 15:53:15.
000000000 +0200
@@ -251,6 +251,13 @@ check_link_down ()
           ip link set dev $1 up >/dev/null 2>&1
           while [ $timeout -le 10 ]; do
+               # VMware-Fixes hinz@linux-systeme.de
+               if LC_ALL=C dmesg | grep -iq vmware ; then
+                       return 1
+               fi
+               if LC_ALL=C /sbin/lspci 2>/dev/null| grep -iq vmware ; then
+                       return 1
+               fi
                check_mii_tool $1
                check_ethtool $1

The true problem is, that ethtool reports the vmware-net-device as "link down".

Unless ethtool or mii-tool do not recognize vmware-net-devices I suggest this 

Comment 2 Suzanne Hillman 2005-04-07 11:14:11 EDT
Please attatch the patch to this bug report, using the "Create a New Attachment"
Comment 3 Joerg Hinz 2005-04-07 13:01:35 EDT
Created attachment 112820 [details]
Patch to fix dhcp-problems with vmware
Comment 4 Bill Nottingham 2005-04-07 14:58:49 EDT
The driver used by vmware does not correctly report link status. This needs to
be fixed there.
Comment 5 John W. Linville 2005-04-07 16:00:06 EDT
Which RHEL3 release are you using?  This sure sounds like bug 100527, which 
should be fixed in RHEL3 U4 or later. 
Please update to RHEL3 U4 (or later) and try to recreate this issue.  If that 
is not possible, please at least try the kernels available here: 
Please report the results here.  Thanks! 
Comment 6 Joerg Hinz 2005-04-13 11:24:37 EDT
Yes, the problem is fixed in RHEL3 U4. Just tested it.

So bug 154106 can be closed.

Thanks for your patience.

Comment 7 Ernie Petrides 2005-04-13 15:06:41 EDT
An errata has been issued which should help the problem 
described in this bug report. This report is therefore being 
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files, 
please follow the link below. You may reopen this bug report 
if the solution does not work for you.


*** This bug has been marked as a duplicate of 100527 ***

Note You need to log in before you can comment on or make changes to this bug.