Bug 1541274 - still uses compat-openssl10-1.0.2m-1.fc27.x86_64
Summary: still uses compat-openssl10-1.0.2m-1.fc27.x86_64
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: ima-evm-utils
Version: 27
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Bruno Meneguele
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-02-02 07:28 UTC by Harald Reindl
Modified: 2018-02-20 17:16 UTC (History)
5 users (show)

Fixed In Version: ima-evm-utils-1.0-3.fc27
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-02-20 17:16:14 UTC
Type: Bug
Embargoed:


Attachments (Terms of Use)

Description Harald Reindl 2018-02-02 07:28:09 UTC
after libssh got fixed in updates-testing this is the last remaining package on a F27 server which still pulls compat-openssl10-1.0.2m-1.fc27.x86_64

[root@testserver:~]$ rpm -e compat-openssl10-1.0.2m-1.fc27.x86_64
error: Failed dependencies:
        libcrypto.so.10()(64bit) is needed by (installed) ima-evm-utils-1.0-2.fc27.x86_64
        libcrypto.so.10(libcrypto.so.10)(64bit) is needed by (installed) ima-evm-utils-1.0-2.fc27.x86_64
        libssl.so.10()(64bit) is needed by (installed) ima-evm-utils-1.0-2.fc27.x86_64

[root@testserver:~]$ rpm -e ima-evm-utils
error: Failed dependencies:
        libimaevm.so.0()(64bit) is needed by (installed) rpm-build-libs-4.14.1-1.fc27.x86_64
        libimaevm.so.0()(64bit) is needed by (installed) python2-rpm-4.14.1-1.fc27.x86_64

Comment 1 Bruno Meneguele 2018-02-02 13:09:10 UTC
Hi Harald,

first of all thanks for the report, but just one question before start: will openssl1.0 compat pkg be removed from F27? Because I already solved this problem to Rawhide (F28) on bug 1516866. This bug was requesting the change only for rawhide, and because of that I didn't port the code to openssl1.1.

Unfortunately this pkg's upstream didn't port the code officially to support openssl1.1, but in case it's really necessary for F27 I can just clone what I've done for F28.

Thanks!

Comment 2 Harald Reindl 2018-02-02 13:11:51 UTC
it won't be removed in F27 but it would be really nice to have the old openssl in the now second release with 1.1.x gone

Comment 3 Harald Reindl 2018-02-02 13:12:36 UTC
p.s.: see other packages in F27 which where "fixed" in the last view days (libssh, uw-imap..)

Comment 4 Bruno Meneguele 2018-02-02 13:16:05 UTC
(In reply to Harald Reindl from comment #2)
> it won't be removed in F27 but it would be really nice to have the old
> openssl in the now second release with 1.1.x gone

Well, ok then. I'll work on that ASAP.
Thanks once again.

Comment 5 Fedora Update System 2018-02-14 17:08:55 UTC
ima-evm-utils-1.0-3.fc27 has been submitted as an update to Fedora 27. https://bodhi.fedoraproject.org/updates/FEDORA-2018-cc855fc149

Comment 6 Harald Reindl 2018-02-14 17:13:56 UTC
Aktualisiert:
  ima-evm-utils.x86_64 1.0-3.fc27

Entfernt:
  compat-openssl10.x86_64 1:1.0.2m-1.fc27

Fertig.
[root@testserver:~]$

dependencies looks good now and dnf still works - thanks!

Comment 7 Fedora Update System 2018-02-15 15:28:19 UTC
ima-evm-utils-1.0-3.fc27 has been pushed to the Fedora 27 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2018-cc855fc149

Comment 8 Fedora Update System 2018-02-20 17:16:14 UTC
ima-evm-utils-1.0-3.fc27 has been pushed to the Fedora 27 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.