This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 154136 - KDE screensavers appear in GNOME menus
KDE screensavers appear in GNOME menus
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kdebase (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ngo Than
Ben Levenson
:
Depends On:
Blocks: FC4Target
  Show dependency treegraph
 
Reported: 2005-04-07 14:20 EDT by Bill Nottingham
Modified: 2014-03-16 22:53 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-04-25 10:56:07 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bill Nottingham 2005-04-07 14:20:15 EDT
Under System Tools -> ScreenSavers the KDE screensavers appear. Presumably they
should have OnlyShowIn, etc.

redhat-menus-3.7.1-9
kdebase-3.4.0-2
Comment 1 Ngo Than 2005-04-07 16:37:27 EDT
it seems a bug in gnome-menus. If you take a look at the
kde-system-screensavers.directory, it includes NoDisplay=true!
The submenue ScreenSavers should not be showed! it works fine under KDE
Comment 2 Mark McLoughlin 2005-04-15 06:47:32 EDT
This turns out to be that kde-essential.menu and kde-multimedia-music.menu need
to have <Name>Applications</Name> in the root <Menu>, otherwise they're not
valid .menu files and gnome-menus won't know anything about
kde-system-screensavers.directory
Comment 3 Ray Strode [halfline] 2005-04-15 10:53:43 EDT
This was worked around by taking <KDELegacyDirs/> out of applications.menu. 
Than,  that shouldn't break KDE because KDE uses kde-applications.menu instead, yea?
Comment 4 Mark McLoughlin 2005-04-15 11:02:10 EDT
Ray: well that's one sure way of making sure we don't get KDE stuff in the menus
alright :-)

FWIW, if we kepth <KDELegacyDirs/>, and just fixed kde-essential.menu and
kde-multimedia.menu, we would be left with:

Accessories/    kde-kmousetool.desktop  
Accessories/    kde-kmouth.desktop      
Edutainment/Miscellaneous/      kde-kwordquiz.desktop   
Graphics/       kde-kmag.desktop        
Internet/       kde-akregator.desktop   
Comment 5 Ngo Than 2005-04-25 10:56:07 EDT
comment#3: yes, kde now uses kde-applications.menu.

it's fixed in current redhat-menus

Note You need to log in before you can comment on or make changes to this bug.