Bug 1541382 - [UPGRADE] (OS::TripleO::Services::ManilaBackendGeneric) could not be found
Summary: [UPGRADE] (OS::TripleO::Services::ManilaBackendGeneric) could not be found
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-tripleo-common
Version: 13.0 (Queens)
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: beta
: 13.0 (Queens)
Assignee: Ryan Brady
QA Contact: Yurii Prokulevych
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-02-02 12:36 UTC by Yurii Prokulevych
Modified: 2018-06-27 13:44 UTC (History)
11 users (show)

Fixed In Version: openstack-tripleo-common-8.5.1-0.20180304032202.e8d9da9.el7ost
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-06-27 13:43:27 UTC
Target Upstream Version:
scohen: needinfo+


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
OpenStack gerrit 542136 None stable/pike: MERGED tripleo-heat-templates: Removes manila-generic-config from TripleO (I2e1db2bd614eae65e59712f50dc3391f16f6b388) 2018-02-21 14:28:05 UTC
Red Hat Product Errata RHEA-2018:2086 None None None 2018-06-27 13:44:12 UTC

Description Yurii Prokulevych 2018-02-02 12:36:50 UTC
Same error as in bz1540546 but specific to ManilaBackendGeneric.

Created for tracking purposes.

Attempt to prepare upgrade playbook fails:
openstack overcloud upgrade --init-update --container-registry-file images.yml
...
u'message': u"Failed to run action [action_ex_id=d2f90517-0e7c-4efd-841b-b4f7ed991800, action_cls='<class 'mistral.actions.action_factory.UpdateStackAction'>', attributes='{}', params='{u'ceph_ansible_playbook'
: u'/usr/share/ceph-ansible/site-docker.yml.sample', u'container': u'overcloud', u'environments': {u'resource_registry': {u'OS::TripleO::Services::FluentdClient': u'OS::Heat::None'}}, u'timeout': 240, u'containe
r_registry': {u'parameter_defaults': {u'DockerNeutronApiImage': u'192.168.24.1:8787/rhosp13/openstack-neutron-server:13.0-20180126.1', u'DockerAodhListenerImage': u'192.168.24.1:8787/rhosp13/openstack-aodh-liste
ner:13.0-20180126.1', u'DockerGnocchiStatsdImage': u'192.168.24.1:8787/rhosp13/openstack-gnocchi-statsd:13.0-20180126.1', u'DockerCeilometerNotificationImage': u'192.168.24.1:8787/rhosp13/openstack-ceilometer-no
tification:13.0-20180126.1', u'DockerHAProxyConfigImage': u'192.168.24.1:8787/rhosp13/openstack-haproxy:13.0-20180126.1', u'DockerRabbitmqImage': u'192.168.24.1:8787/rhosp13/openstack-rabbitmq:13.0-20180126.1', 
u'DockerNovaConsoleauthImage': u'192.168.24.1:8787/rhosp13/openstack-nova-consoleauth:13.0-20180126.1', u'DockerAodhConfigImage': u'192.168.24.1:8787/rhosp13/openstack-aodh-api:13.0-20180126.1', u'DockerInsecure
RegistryAddress': [u'192.168.24.1:8787'], u'DockerIscsidImage': u'192.168.24.1:8787/rhosp13/openstack-iscsid:13.0-20180126.1', u'DockerGnocchiMetricdImage': u'192.168.24.1:8787/rhosp13/openstack-gnocchi-metricd:
13.0-20180126.1', u'DockerIscsidConfigImage': u'192.168.24.1:8787/rhosp13/openstack-iscsid:13.0-20180126.1', u'DockerNovaMetadataImage': u'192.168.24.1:8787/rhosp13/openstack-nova-api:13.0-20180126.1', u'DockerC
inderApiImage': u'192.168.24.1:8787/rhosp13/openstack-cinder-api:13.0-20180126.1', u'DockerNovaComputeImage': u'192.168.24.1:8787/rhosp13/openstack-nova-compute:13.0-20180126.1', u'DockerGnocchiConfigImage': u'1
92.168.24.1:8787/rhosp13/openstack-gnocchi-api:13.0-20180126.1', u'DockerCeilometerCentralImage': u'192.168.24.1:8787/rhosp13/openstack-ceilometer-central:13.0-20180126.1', u'DockerNeutronL3AgentImage': u'192.16
8.24.1:8787/rhosp13/openstack-neutron-l3-agent:13.0-20180126.1', u'DockerCeilometerComputeImage': u'192.168.24.1:8787/rhosp13/openstack-ceilometer-compute:13.0-20180126.1', u'DockerRedisImage': u'192.168.24.1:87
87/rhosp13/openstack-redis:13.0-20180126.1', u'DockerClustercheckImage': u'192.168.24.1:8787/rhosp13/openstack-mariadb:13.0-20180126.1', u'DockerHorizonImage': u'192.168.24.1:8787/rhosp13/openstack-horizon:13.0-
20180126.1', u'DockerCinderConfigImage': u'192.168.24.1:8787/rhosp13/openstack-cinder-api:13.0-20180126.1', u'DockerSwiftContainerImage': u'192.168.24.1:8787/rhosp13/openstack-swift-container:13.0-20180126.1', u
'DockerGnocchiApiImage': u'192.168.24.1:8787/rhosp13/openstack-gnocchi-api:13.0-20180126.1', u'DockerMysqlImage': u'192.168.24.1:8787/rhosp13/openstack-mariadb:13.0-20180126.1', u'DockerAodhEvaluatorImage': u'19
2.168.24.1:8787/rhosp13/openstack-aodh-evaluator:13.0-20180126.1', u'DockerPankoApiImage': u'192.168.24.1:8787/rhosp13/openstack-panko-api:13.0-20180126.1', u'DockerNovaApiImage': u'192.168.24.1:8787/rhosp13/ope
nstack-nova-api:13.0-20180126.1', u'DockerMysqlClientConfigImage': u'192.168.24.1:8787/rhosp13/openstack-mariadb:13.0-20180126.1', u'DockerNovaVncProxyImage': u'192.168.24.1:8787/rhosp13/openstack-nova-novncprox
y:13.0-20180126.1', u'DockerClustercheckConfigImage': u'192.168.24.1:8787/rhosp13/openstack-mariadb:13.0-20180126.1', u'DockerNeutronMetadataImage': u'192.168.24.1:8787/rhosp13/openstack-neutron-metadata-agent:1
3.0-20180126.1', u'DockerKeystoneImage': u'192.168.24.1:8787/rhosp13/openstack-keystone:13.0-20180126.1', u'DockerCephDaemonImage': u'192.168.24.1:8787/rhceph/rhceph-3-rhel7:latest', u'DockerNovaConductorImage':
 u'192.168.24.1:8787/rhosp13/openstack-nova-conductor:13.0-20180126.1', u'DockerNovaPlacementConfigImage': u'192.168.24.1:8787/rhosp13/openstack-nova-placement-api:13.0-20180126.1', u'DockerNovaLibvirtImage': u'
192.168.24.1:8787/rhosp13/openstack-nova-libvirt:13.0-20180126.1', u'DockerMysqlConfigImage': u'192.168.24.1:8787/rhosp13/openstack-mariadb:13.0-20180126.1', u'DockerRabbitmqConfigImage': u'192.168.24.1:8787/rho
sp13/openstack-rabbitmq:13.0-20180126.1', u'DockerKeystoneConfigImage': u'192.168.24.1:8787/rhosp13/openstack-keystone:13.0-20180126.1', u'DockerAodhApiImage': u'192.168.24.1:8787/rhosp13/openstack-aodh-api:13.0
-20180126.1', u'DockerCinderSchedulerImage': u'192.168.24.1:8787/rhosp13/openstack-cinder-scheduler:13.0-20180126.1', u'DockerMemcachedImage': u'192.168.24.1:8787/rhosp13/openstack-memcached:13.0-20180126.1', u'
DockerHeatApiCfnImage': u'192.168.24.1:8787/rhosp13/openstack-heat-api-cfn:13.0-20180126.1', u'DockerNovaConfigImage': u'192.168.24.1:8787/rhosp13/openstack-nova-api:13.0-20180126.1', u'DockerSwiftAccountImage':
 u'192.168.24.1:8787/rhosp13/openstack-swift-account:13.0-20180126.1', u'DockerGlanceApiImage': u'192.168.24.1:8787/rhosp13/openstack-glance-api:13.0-20180126.1', u'DockerGlanceApiConfigImage': u'192.168.24.1:87
87/rhosp13/openstack-glance-api:13.0-20180126.1', u'DockerNeutronConfigImage': u'192.168.24.1:8787/rhosp13/openstack-neutron-server:13.0-20180126.1', u'DockerMemcachedConfigImage': u'192.168.24.1:8787/rhosp13/op
enstack-memcached:13.0-20180126.1', u'DockerHeatApiCfnConfigImage': u'192.168.24.1:8787/rhosp13/openstack-heat-api-cfn:13.0-20180126.1', u'DockerHeatConfigImage': u'192.168.24.1:8787/rhosp13/openstack-heat-api:1
3.0-20180126.1', u'DockerAodhNotifierImage': u'192.168.24.1:8787/rhosp13/openstack-aodh-notifier:13.0-20180126.1', u'DockerSwiftProxyImage': u'192.168.24.1:8787/rhosp13/openstack-swift-proxy-server:13.0-20180126
.1', u'DockerCrondImage': u'192.168.24.1:8787/rhosp13/openstack-cron:13.0-20180126.1', u'DockerHeatApiConfigImage': u'192.168.24.1:8787/rhosp13/openstack-heat-api:13.0-20180126.1', u'DockerSwiftObjectImage': u'1
92.168.24.1:8787/rhosp13/openstack-swift-object:13.0-20180126.1', u'DockerHorizonConfigImage': u'192.168.24.1:8787/rhosp13/openstack-horizon:13.0-20180126.1', u'DockerNovaLibvirtConfigImage': u'192.168.24.1:8787
/rhosp13/openstack-nova-compute:13.0-20180126.1', u'DockerRedisConfigImage': u'192.168.24.1:8787/rhosp13/openstack-redis:13.0-20180126.1', u'DockerPankoConfigImage': u'192.168.24.1:8787/rhosp13/openstack-panko-a
pi:13.0-20180126.1', u'DockerHeatApiImage': u'192.168.24.1:8787/rhosp13/openstack-heat-api:13.0-20180126.1', u'DockerNovaSchedulerImage': u'192.168.24.1:8787/rhosp13/openstack-nova-scheduler:13.0-20180126.1', u'
DockerNovaPlacementImage': u'192.168.24.1:8787/rhosp13/openstack-nova-placement-api:13.0-20180126.1', u'DockerSwiftConfigImage': u'192.168.24.1:8787/rhosp13/openstack-swift-proxy-server:13.0-20180126.1', u'Docke
rCrondConfigImage': u'192.168.24.1:8787/rhosp13/openstack-cron:13.0-20180126.1', u'DockerCeilometerConfigImage': u'192.168.24.1:8787/rhosp13/openstack-ceilometer-central:13.0-20180126.1', u'DockerHeatEngineImage
': u'192.168.24.1:8787/rhosp13/openstack-heat-engine:13.0-20180126.1', u'DockerOpenvswitchImage': u'192.168.24.1:8787/rhosp13/openstack-neutron-openvswitch-agent:13.0-20180126.1', u'DockerNeutronDHCPImage': u'19
2.168.24.1:8787/rhosp13/openstack-neutron-dhcp-agent:13.0-20180126.1', u'DockerHAProxyImage': u'192.168.24.1:8787/rhosp13/openstack-haproxy:13.0-20180126.1', u'DockerCinderVolumeImage': u'192.168.24.1:8787/rhosp
13/openstack-cinder-volume:13.0-20180126.1'}}}']\n ERROR: resources.CephStorageServiceChain<https://192.168.24.2:13808/v1/AUTH_9cf3b65b76234773a1ce897bd47dcdcf/overcloud/common/services.yaml>: : The Resource Typ
e (OS::TripleO::Services::FluentdClient) could not be found.",
 u'status': u'FAILED'}

Version-Release number of selected component (if applicable):
-------------------------------------------------------------
openstack-tripleo-heat-templates-8.0.0-0.20180122224016.el7ost.noarch


How reproducible:
-----------------
100%


Steps to Reproduce:
-------------------
1. Install RHOS-12 env
2. Install 2018-01-26.3 repos
3. Upgrade uc
4. Apply patches: 526213 and 526214
5. Prepare images
6. Run upgrade init:
    openstack overcloud upgrade --init-update --container-registry-file images.yml

Actual results:
---------------
Upgrade playbook is not generated

Expected results:
-----------------
upgrade init command succeeds

Comment 13 Yurii Prokulevych 2018-05-09 15:07:21 UTC
Verified with
openstack-tripleo-heat-templates-8.0.2-14.el7ost.noarch
openstack-tripleo-common-8.6.1-7.el7ost.noarch

Comment 15 errata-xmlrpc 2018-06-27 13:43:27 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2018:2086


Note You need to log in before you can comment on or make changes to this bug.