Bug 1541389 - wrong packaging of ioprocess rpm
Summary: wrong packaging of ioprocess rpm
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: ovirt-distribution
Classification: oVirt
Component: ioprocess
Version: 4.2.0
Hardware: Unspecified
OS: Unspecified
unspecified
urgent
Target Milestone: ovirt-4.2.2
: ---
Assignee: Nir Soffer
QA Contact: Pavol Brilla
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-02-02 13:11 UTC by Sandro Bonazzola
Modified: 2018-03-06 17:18 UTC (History)
4 users (show)

Fixed In Version: ioprocess-1.0.2-1.fc27
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-03-06 17:18:46 UTC
oVirt Team: Storage
rule-engine: ovirt-4.2?
rule-engine: blocker+
tnisan: planning_ack?
tnisan: devel_ack+
lsvaty: testing_ack+


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
oVirt gerrit 87096 None None None 2018-02-02 19:47:30 UTC

Description Sandro Bonazzola 2018-02-02 13:11:17 UTC
Description of problem:
In the spec file %{?python_provide:%python_provide python-ioprocess} is used for autogenerating suitable obsoletes and provides on Fedora systems.

But on EL7 systems the macro is not defined and no obsoletes is provided, thus causing repository closure errors and dependency resolution errors like:

11:58:12 Error: Package: python-ioprocess-1.0.0-1.201711301358.git33b51a0.el7.centos.noarch (alocalsync)
11:58:12            Requires: ioprocess = 1.0.0
11:58:12            Available: ioprocess-1.0.1-1.201801311946.git21b547a.el7.centos.x86_64 (alocalsync)
11:58:12                ioprocess = 1.0.1-1.201801311946.git21b547a.el7.centos

since python2-ioprocess-1.0.1-1.201801311946.git21b547a.el7.centos doesn't provide/obsolete python-ioprocess

Comment 1 Nir Soffer 2018-02-02 20:06:35 UTC
The regression was introduced 6 weeks ago in:
https://gerrit.ovirt.org/gitweb?p=ioprocess.git;a=commit;h=bc3427e2630f45eca90bf9533d06710aa0f245db

I wonder why it was discovered only now. Maybe we are missing some tests that
should run after every merge, or maybe daily?

Comment 2 Nir Soffer 2018-02-04 11:35:57 UTC
Fix will be available in ioprocess-1.0.2.

Comment 3 Fedora Update System 2018-02-04 13:25:48 UTC
ioprocess-1.0.2-1.fc27 has been submitted as an update to Fedora 27. https://bodhi.fedoraproject.org/updates/FEDORA-2018-5fc2a37e8a

Comment 6 Fedora Update System 2018-02-04 20:18:36 UTC
ioprocess-1.0.2-1.fc27 has been pushed to the Fedora 27 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2018-5fc2a37e8a

Comment 7 Pavol Brilla 2018-02-19 09:01:07 UTC
RHEL7# rpm -qa --qf '[%{obsoletes}\n]' python2-ioprocess
python-ioprocess
RHEL7# yum list python2-ioprocess
Installed Packages
python2-ioprocess.noarch        1.0.2-1.el7ev            @rhv-4.2.x

Comment 8 Sandro Bonazzola 2018-02-20 08:40:59 UTC
(In reply to Nir Soffer from comment #1)
> The regression was introduced 6 weeks ago in:
> https://gerrit.ovirt.org/gitweb?p=ioprocess.git;a=commit;
> h=bc3427e2630f45eca90bf9533d06710aa0f245db
> 
> I wonder why it was discovered only now. Maybe we are missing some tests that
> should run after every merge, or maybe daily?

No idea. You can try to talk with CI team and see how we can improve.

Comment 9 Fedora Update System 2018-03-06 17:18:46 UTC
ioprocess-1.0.2-1.fc27 has been pushed to the Fedora 27 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.