Bug 1541759 - Failed to deploy Node Zero with "[ ERROR ] Failed to execute stage 'Clean up': 'NoneType' object has no attribute 'cleanup'"
Summary: Failed to deploy Node Zero with "[ ERROR ] Failed to execute stage 'Clean up'...
Keywords:
Status: CLOSED DUPLICATE of bug 1541233
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-hosted-engine-setup
Version: 4.2.0
Hardware: x86_64
OS: Linux
unspecified
urgent
Target Milestone: ---
: ---
Assignee: Sandro Bonazzola
QA Contact: meital avital
URL:
Whiteboard:
Depends On:
Blocks: 1455169
TreeView+ depends on / blocked
 
Reported: 2018-02-04 14:52 UTC by Nikolai Sednev
Modified: 2019-05-16 12:54 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-02-05 08:10:49 UTC
oVirt Team: Integration
Target Upstream Version:


Attachments (Terms of Use)
sosreport from puma19 (9.14 MB, application/x-xz)
2018-02-04 14:56 UTC, Nikolai Sednev
no flags Details

Description Nikolai Sednev 2018-02-04 14:52:59 UTC
Description of problem:
Failed to deploy Node Zero with "[ ERROR ] Failed to execute stage 'Clean up': 'NoneType' object has no attribute 'cleanup'"

Version-Release number of selected component (if applicable):
ovirt-hosted-engine-setup-2.2.9-1.el7ev.noarch
ovirt-hosted-engine-ha-2.2.4-1.el7ev.noarch
rhvm-appliance-4.2-20180201.0.el7.noarch

How reproducible:
100%

Steps to Reproduce:
1.Deploy SHE using ansible.

Actual results:
Deployment failed.

Expected results:
Should succeed.

Additional info:
Engine was not accessible during deployment via sshe, I could not gather logs from it.
http://pastebin.test.redhat.com/552650
Sosreport from host appears within the attachment.

Comment 1 Nikolai Sednev 2018-02-04 14:56:22 UTC
Created attachment 1390967 [details]
sosreport from puma19

Comment 2 Yaniv Kaul 2018-02-04 19:02:41 UTC
NFS? iSCSI? All? With Cockpit or CLI?
Missing some information...

Comment 3 Simone Tiraboschi 2018-02-05 08:10:49 UTC
[ ERROR ] fatal: [nsednev-he-4.scl.lab.tlv.redhat.com]: FAILED! => {"changed": true, "cmd": ["/usr/bin/engine-setup", "--offline", "--config-append=/root/ovirt-engine-answers", "--config-append=/root/heanswers.conf"], "delta": "0:00:01.651093", "end": "2018-02-04 16:26:31.229317", "msg": "non-zero return code", "rc": 1, "start": "2018-02-04 16:26:29.578224", "stderr": "", "stderr_lines": [], "stdout": "[ INFO  ] Stage: Initializing\n[ INFO  ] Stage: Environment setup\n          Configuration files: ['/etc/ovirt-engine-setup.conf.d/10-packaging-wsp.conf', '/etc/ovirt-engine-setup.conf.d/10-packaging.conf', '/root/ovirt-engine-answers', '/root/heanswers.conf']\n          Log file: /var/log/ovirt-engine/setup/ovirt-engine-setup-20180204162630-upy1rz.log\n          Version: otopi-1.7.7 (otopi-1.7.7-1.el7ev)\n[ ERROR ] \"before\" parameter of method otopi.plugins.ovirt_engine_setup.ovirt_engine.network.ovirtproviderovn.Plugin._misc_configure_ovn_pki is a string, should probably be a tuple. Perhaps a missing comma?\n          methodinfo: {'priority': 5000, 'name': None, 'before': 'osetup.ovn.provider.service.restart', 'after': ('osetup.pki.ca.available', 'osetup.ovn.services.restart'), 'method': <bound method ?._misc_configure_ovn_pki of <otopi.plugins.ovirt_engine_setup.ovirt_engine.network.ovirtproviderovn.Plugin object at 0x18d9490>>, 'condition': <bound method ?.<lambda> of <otopi.plugins.ovirt_engine_setup.ovirt_engine.network.ovirtproviderovn.Plugin object at 0x18d9490>>, 'stage': 11}\n[ ERROR ] \"before\" parameter of method otopi.plugins.ovirt_engine_setup.ovirt_engine.network.ovirtproviderovn.Plugin._misc_configure_provider is a string, should probably be a tuple. Perhaps a missing comma?\n          methodinfo: {'priority': 5000, 'name': None, 'before': 'osetup.ovn.provider.service.restart', 'after': ('osetup.pki.ca.available', 'osetup.ovn.services.restart'), 'method': <bound method ?._misc_configure_provider of <otopi.plugins.ovirt_engine_setup.ovirt_engine.network.ovirtproviderovn.Plugin object at 0x18d9490>>, 'condition': <bound method ?.<lambda> of <otopi.plugins.ovirt_engine_setup.ovirt_engine.network.ovirtproviderovn.Plugin object at 0x18d9490>>, 'stage': 11}\n[ ERROR ] Failed to execute stage 'Environment setup': Found bad \"before\" or \"after\" parameters\n[ INFO  ] Stage: Clean up\n          Log file is located at /var/log/ovirt-engine/setup/ovirt-engine-setup-20180204162630-upy1rz.log\n[ ERROR ] Failed to execute stage 'Clean up': 'NoneType' object has no attribute 'cleanup'\n[ INFO  ] Generating answer file '/var/lib/ovirt-engine/setup/answers/20180204162631-setup.conf'\n[ INFO  ] Stage: Pre-termination\n[ INFO  ] Stage: Termination\n[ ERROR ] Execution of setup failed", "stdout_lines": ["[ INFO  ] Stage: Initializing", "[ INFO  ] Stage: Environment setup", "          Configuration files: ['/etc/ovirt-engine-setup.conf.d/10-packaging-wsp.conf', '/etc/ovirt-engine-setup.conf.d/10-packaging.conf', '/root/ovirt-engine-answers', '/root/heanswers.conf']", "          Log file: /var/log/ovirt-engine/setup/ovirt-engine-setup-20180204162630-upy1rz.log", "          Version: otopi-1.7.7 (otopi-1.7.7-1.el7ev)", "[ ERROR ] \"before\" parameter of method otopi.plugins.ovirt_engine_setup.ovirt_engine.network.ovirtproviderovn.Plugin._misc_configure_ovn_pki is a string, should probably be a tuple. Perhaps a missing comma?", "          methodinfo: {'priority': 5000, 'name': None, 'before': 'osetup.ovn.provider.service.restart', 'after': ('osetup.pki.ca.available', 'osetup.ovn.services.restart'), 'method': <bound method ?._misc_configure_ovn_pki of <otopi.plugins.ovirt_engine_setup.ovirt_engine.network.ovirtproviderovn.Plugin object at 0x18d9490>>, 'condition': <bound method ?.<lambda> of <otopi.plugins.ovirt_engine_setup.ovirt_engine.network.ovirtproviderovn.Plugin object at 0x18d9490>>, 'stage': 11}", "[ ERROR ] \"before\" parameter of method otopi.plugins.ovirt_engine_setup.ovirt_engine.network.ovirtproviderovn.Plugin._misc_configure_provider is a string, should probably be a tuple. Perhaps a missing comma?", "          methodinfo: {'priority': 5000, 'name': None, 'before': 'osetup.ovn.provider.service.restart', 'after': ('osetup.pki.ca.available', 'osetup.ovn.services.restart'), 'method': <bound method ?._misc_configure_provider of <otopi.plugins.ovirt_engine_setup.ovirt_engine.network.ovirtproviderovn.Plugin object at 0x18d9490>>, 'condition': <bound method ?.<lambda> of <otopi.plugins.ovirt_engine_setup.ovirt_engine.network.ovirtproviderovn.Plugin object at 0x18d9490>>, 'stage': 11}", "[ ERROR ] Failed to execute stage 'Environment setup': Found bad \"before\" or \"after\" parameters", "[ INFO  ] Stage: Clean up", "          Log file is located at /var/log/ovirt-engine/setup/ovirt-engine-setup-20180204162630-upy1rz.log", "[ ERROR ] Failed to execute stage 'Clean up': 'NoneType' object has no attribute 'cleanup'", "[ INFO  ] Generating answer file '/var/lib/ovirt-engine/setup/answers/20180204162631-setup.conf'", "[ INFO  ] Stage: Pre-termination", "[ INFO  ] Stage: Termination", "[ ERROR ] Execution of setup failed"]}

It was a bug on engine-setup on the appliance.
We already fixed and shipped a fresh appliance.

*** This bug has been marked as a duplicate of bug 1541233 ***

Comment 4 Nikolai Sednev 2018-02-05 11:00:03 UTC
(In reply to Yaniv Kaul from comment #2)
> NFS? iSCSI? All? With Cockpit or CLI?
> Missing some information...

1.Cockpit on RHEL is not working and not supported.
2.Deployment fails on its early stages, even without getting to storage type.
3.RHEL based deployment being always executed using CLI.

Comment 5 Nikolai Sednev 2018-02-05 11:02:20 UTC
bug 1541233 had been verified, but it still happens on RHEL components as was described at the description section.
Please consider on reopening this bug as it still reproducible on RHEL.

Comment 6 Sandro Bonazzola 2018-02-05 12:07:25 UTC
(In reply to Nikolai Sednev from comment #5)
> bug 1541233 had been verified, but it still happens on RHEL components as
> was described at the description section.
> Please consider on reopening this bug as it still reproducible on RHEL.

which version of the appliance are you using?
rhvm-appliance-4.2-20180202.0 ?

Comment 7 Nikolai Sednev 2018-02-05 12:18:54 UTC
Just as was mentioned within the description: rhvm-appliance-4.2-20180201.0.el7.noarch.

Comment 8 Simone Tiraboschi 2018-02-05 12:32:21 UTC
(In reply to Nikolai Sednev from comment #4)
> 1.Cockpit on RHEL is not working and not supported.

AFAIK it should work as well.

Comment 9 Franta Kust 2019-05-16 12:54:38 UTC
BZ<2>Jira re-sync


Note You need to log in before you can comment on or make changes to this bug.