Bug 1541885 - Disconnected satellite access internet to install gem "oauth-0.5.1.gem"
Summary: Disconnected satellite access internet to install gem "oauth-0.5.1.gem"
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Packaging
Version: 6.3.0
Hardware: x86_64
OS: All
high
urgent vote
Target Milestone: Unspecified
Assignee: satellite6-bugs
QA Contact: Lukas Pramuk
URL:
Whiteboard:
Depends On:
Blocks: 1122832
TreeView+ depends on / blocked
 
Reported: 2018-02-05 06:42 UTC by Ranjan Kumar
Modified: 2019-06-13 21:26 UTC (History)
9 users (show)

Fixed In Version: puppet-agent-oauth-0.5.1-3
Doc Type: Known Issue
Doc Text:
*For ISO-based disconnected Satellite users* *Known Issue* The RPM script is missing "--local", which makes it search the internet to install the "oauth" gem. For disconnected Satellites, this is a problem. *Workaround* If Puppet 4 is installed, when `yum` installs packages using the default Puppet 4 repositories, before you run `satellite-installer`, enter the following command: `/opt/puppetlabs/puppet/bin/gem install --local /usr/share/foreman-installer/gems/oauth-0.5.1.gem` *Workaround* If you upgrade to Puppet 4, before you enter the `--upgrade-puppet` command, enter the following commands: ---- yum remove -y puppet-server yum install puppetserver puppet-agent puppet-agent-oauth /opt/puppetlabs/puppet/bin/gem install --local /usr/share/foreman-installer/gems/oauth-0.5.1.gem ----
Clone Of:
Environment:
Last Closed: 2018-04-13 13:29:48 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2018:1126 None None None 2018-04-13 13:31:33 UTC

Description Ranjan Kumar 2018-02-05 06:42:04 UTC
Description of problem:
The rpm scriptlet missing "--local" causing it to go to the internet to install "oauth" gem.  This is not acceptable for disconnected installation.
This gem is locally available at /usr/share/foreman-installer/gems/oauth-0.5.1.gem


Post Install scriptlet
--------------------------
# rpm -q --scripts --info puppet-agent-oauth
postinstall scriptlet (using /bin/sh):
/opt/puppetlabs/puppet/bin/gem install /usr/share/foreman-installer/gems/oauth-0.5.1.gem >/dev/null
preuninstall scriptlet (using /bin/sh):
/opt/puppetlabs/puppet/bin/gem uninstall -x -v 0.5.1 oauth >/dev/null
Name        : puppet-agent-oauth
Version     : 0.5.1
Release     : 2.el7sat
Architecture: noarch
Install Date: Thu 23 Nov 2017 12:02:04 PM IST
Group       : Development/Languages
Size        : 43520
License     : MIT
Signature   : RSA/SHA256, Wed 01 Nov 2017 10:47:22 PM IST, Key ID 938a80caf21541eb
Source RPM  : puppet-agent-oauth-0.5.1-2.el7sat.src.rpm
Build Date  : Wed 09 Nov 2016 07:34:41 PM IST
Build Host  : x86-019.build.eng.bos.redhat.com
Relocations : (not relocatable)
Packager    : Red Hat, Inc. <http://bugzilla.redhat.com/bugzilla>
Vendor      : Red Hat, Inc.
URL         : http://rubydoc.info/gems/oauth
Summary     : OAuth Core Ruby implementation for Puppet Agent
Description :
OAuth Core Ruby implementation for Puppet Agent.


Below is the sample fix to the scriptlet:
--------------------------------------------
rpm --noscripts -i ./puppet-agent-oauth-0.5.1-2.el7sat.noarch.rpm
/opt/puppetlabs/puppet/bin/gem install --local /usr/share/foreman-installer/gems/oauth-0.5.1.gem



Version-Release number of selected component (if applicable): 6.3


Actual results: Tries to install gem using internet


Expected results: It should install local gems available at /usr/share/foreman-installer/gems/oauth-0.5.1.gem

Comment 4 Peter Vreman 2018-02-26 17:08:00 UTC
This bug affects also all users that have use proxy

I have subscription-manager working through proxy and also Sat6 will be configured using a proxy.

Comment 7 Lukas Pramuk 2018-04-04 10:31:50 UTC
VERIFIED.

@satellite-6.3.1-3.el7sat.noarch
puppet-agent-oauth-0.5.1-3.el7sat.noarch.rpm

by following manual reproducer:

1) Have a SAT6.3.1 Puppet3

2) Enable Satellite Puppet4 repo (internal repo with the new package)

3) Install P4 packages except oauth

# yum remove -y puppet-server
# yum install puppetserver puppet-agent
# yumdownloader puppet-agent-oauth

4) Start to watch ruby network traffic in other console window by running

# watch -n.5 'netstat -pnt|grep ruby'

5) Install puppet-agent-oauth from downloaded rpm and watch for any connections

# rpm -i puppet-agent-oauth-0.5.1-3.el7sat.noarch.rpm

>>> no connections were initiated (vs. 0.5.1-2.el7sat)

Comment 9 errata-xmlrpc 2018-04-13 13:29:48 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:1126


Note You need to log in before you can comment on or make changes to this bug.