Bug 1541965 - neutron* containers always logging to stdout
Summary: neutron* containers always logging to stdout
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: puppet-oslo
Version: 13.0 (Queens)
Hardware: x86_64
OS: Linux
urgent
urgent
Target Milestone: beta
: 13.0 (Queens)
Assignee: Assaf Muller
QA Contact: Roee Agiman
URL:
Whiteboard:
: 1540499 (view as bug list)
Depends On:
Blocks: 1540949
TreeView+ depends on / blocked
 
Reported: 2018-02-05 10:33 UTC by Artem Hrechanychenko
Modified: 2018-06-27 13:44 UTC (History)
11 users (show)

Fixed In Version: puppet-oslo-12.3.1-0.20180221081308.3f4f066.el7ost
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-06-27 13:43:27 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
OpenStack gerrit 534629 'None' MERGED Revert "Update olso.log parameters" 2020-08-02 15:54:08 UTC
Red Hat Product Errata RHEA-2018:2086 None None None 2018-06-27 13:44:12 UTC

Description Artem Hrechanychenko 2018-02-05 10:33:49 UTC
Description of problem:
[heat-admin@controller-0 ~]$ sudo ls /var/log/containers/
aodh  ceilometer  cinder  glance  gnocchi  heat  horizon  httpd  keystone  memcached  neutron  nova  panko  swift
[heat-admin@controller-0 ~]$ sudo ls /var/log/containers/neutron
[heat-admin@controller-0 ~]$ 

[heat-admin@controller-0 ~]$ sudo docker exec -it neutron_api /bin/bash 
tput: No value for $TERM and no -T specified
tput: No value for $TERM and no -T specified
()[neutron@controller-0 /]$ ls /var/log/neutron/                                                                                                                                                                  
tput: No value for $TERM and no -T specified
tput: No value for $TERM and no -T specified
()[neutron@controller-0 /]$ 


the same for 
2447e6d76914        192.168.24.1:8787/rhosp13/openstack-neutron-openvswitch-agent:2018-01-26.3   "kolla_start"            2 days ago          Up 2 days (healthy)                       neutron_ovs_agent
25e728ce5cab        192.168.24.1:8787/rhosp13/openstack-neutron-l3-agent:2018-01-26.3            "kolla_start"            2 days ago          Up 2 days (healthy)                       neutron_l3_agent
ff124f055e78        192.168.24.1:8787/rhosp13/openstack-neutron-metadata-agent:2018-01-26.3      "kolla_start"            2 days ago          Up 2 days (healthy)                       neutron_metadata_agent
a9a4458d7bd0        192.168.24.1:8787/rhosp13/openstack-neutron-dhcp-agent:2018-01-26.3          "kolla_start"            2 days ago          Up 2 days (healthy)                       neutron_dhcp
eddc949d7290        192.168.24.1:8787/rhosp13/openstack-neutron-server:2018-01-26.3              "kolla_start"            2 days ago          Up 2 days                                 neutron_api

Version-Release number of selected component (if applicable):
docker images:2018-01-26.3  

How reproducible:
always

Steps to Reproduce:
1. Deploy OSP13
2. Check /var/log/containers on OC node

Actual results:
/var/log/containers/neutron is empty

Expected results:
/var/log/containers/neutron isn't empty

Additional info:

Comment 2 Assaf Muller 2018-02-07 14:42:27 UTC
*** Bug 1540499 has been marked as a duplicate of this bug. ***

Comment 3 Assaf Muller 2018-02-07 14:45:23 UTC
Brent added on a Networking DFG call that this is likely a recent regression. Assigned to Or to investigate.

Comment 6 Daniel Alvarez Sanchez 2018-02-08 16:48:24 UTC
This same thing happened to me today with ovn metadata agent.
I found out that we're searching for log_dir apparently and the option configured by TripleO is log-dir:

[root@overcloud-novacompute-0 neutron]# pwd
/var/lib/config-data/puppet-generated/neutron/etc/neutron
[root@overcloud-novacompute-0 neutron]# grep log-dir neutron.conf 
log-dir=/var/log/neutron

After I changed it to log_dir, I could verify that it started to log to /var/log/neutron (/var/log/containers/neutron) outside the container.

The reason why this fails is because of this patch [0] which makes oslo-puppet to write the "xxx-xxx" variables but then argparser will convert it to "xxx_xxx". My understanding is that [0] should be reverted.

[0] https://review.openstack.org/#/c/444345/6/manifests/log.pp@157

Comment 7 Daniel Alvarez Sanchez 2018-02-08 17:10:58 UTC
This is the revert: https://review.openstack.org/#/c/534629/

Comment 13 errata-xmlrpc 2018-06-27 13:43:27 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2018:2086


Note You need to log in before you can comment on or make changes to this bug.