Bug 15421 - XFree 4 induces core dump of legacy openlook apps
Summary: XFree 4 induces core dump of legacy openlook apps
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: XFree86   
(Show other bugs)
Version: 7.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Mike A. Harris
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-08-04 17:43 UTC by Philip Long
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-11-14 17:40:49 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Philip Long 2000-08-04 17:43:47 UTC
In house we have some legacy openlook apps that we are replacing with Java
apps.

These applications are now summarily dumping core when trying to display on
the 
4.0.1 server.  They are fine on the 3.3.6 server.

If I get a chance I'll see where they are doing it and update this message

Comment 1 Philip Long 2000-08-09 22:05:49 UTC
The (remote) programs are failing on XtAppInitialize with signal 11


Comment 2 Mike A. Harris 2001-03-23 09:00:55 UTC
If the remote programs are coredumping then there is a bug in the remote
applications IMHO. You would have to get a backtrace of a coring app,
and track down where the problem is occuring.  It likely is just a bad
assumption in the app of something that has changed.  It is hard to say
without more info though.

I have nothing here to reproduce it. Xt apps are also considered legacy as
you mention, and Xt is quite unsupported by the XFree86 team for the most
part.  If a bug can be traced directly o XFree, and enough info supplied to
fix the bug, or someone submits a patch that fixes a bug, then I'll apply it
and submit it to XFree86, but I don't currently consider this a bug in XFree86.


Note You need to log in before you can comment on or make changes to this bug.