Bug 1542382 - Add quorum checks in post-op
Summary: Add quorum checks in post-op
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: replicate
Version: 4.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Ravishankar N
QA Contact:
URL:
Whiteboard:
Depends On: 1506140 1597120
Blocks: 1384983 1536346
TreeView+ depends on / blocked
 
Reported: 2018-02-06 09:01 UTC by Ravishankar N
Modified: 2018-07-02 06:14 UTC (History)
1 user (show)

Fixed In Version: glusterfs-4.0.0
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1506140
Environment:
Last Closed: 2018-03-15 11:26:23 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Ravishankar N 2018-02-06 09:01:23 UTC
+++ This bug was initially created as a clone of Bug #1506140 +++

afr relies on pending changelog xattrs to identify source and sinks and the
setting of these xattrs happen in post-op. So if post-op fails, we need to
unwind the write txn with a failure.

--- Additional comment from Worker Ant on 2017-10-25 04:58:01 EDT ---

REVIEW: https://review.gluster.org/18571 (afr: add quorum checks in post-op) posted (#1) for review on master by Ravishankar N (ravishankar@redhat.com)

--- Additional comment from Worker Ant on 2018-01-19 03:11:15 EST ---

COMMIT: https://review.gluster.org/18571 committed in master by \"Ravishankar N\" <ravishankar@redhat.com> with a commit message- afr: add quorum checks in post-op

afr relies on pending changelog xattrs to identify source and sinks and the
setting of these xattrs happen in post-op. So if post-op fails, we need to
unwind the write txn with a failure.

Change-Id: I0f019ac03890108324ee7672883d774918b20be1
BUG: 1506140
Signed-off-by: Ravishankar N <ravishankar@redhat.com>

--- Additional comment from Ravishankar N on 2018-01-28 22:22:10 EST ---

Moving back to POST, need to send a follow-up patch  for the one in comment #2, to use the actual errnos from  bricks without returning ENOTCONN if post-op quorum is not met.

--- Additional comment from Worker Ant on 2018-01-29 11:01:21 EST ---

REVIEW: https://review.gluster.org/19366 (afr: simplify post-op quorum checks) posted (#1) for review on master by Ravishankar N

--- Additional comment from Worker Ant on 2018-01-31 08:59:44 EST ---

COMMIT: https://review.gluster.org/19366 committed in master by "Amar Tumballi" <amarts@redhat.com> with a commit message- afr: capture the correct errno in post-op quorum check

If the post-op phase of txn did not meet quorm checks, use that errno to
unwind the FOP rather than blindly setting ENOTCONN.

Change-Id: I0cb0c8771ec75a45f9a25ad4cd8601103deddf0c
BUG: 1506140
Signed-off-by: Ravishankar N <ravishankar@redhat.com>

Comment 1 Worker Ant 2018-02-06 09:04:48 UTC
REVIEW: https://review.gluster.org/19506 (afr: capture the correct errno in post-op quorum check) posted (#1) for review on release-4.0 by Ravishankar N

Comment 2 Worker Ant 2018-02-06 14:26:02 UTC
COMMIT: https://review.gluster.org/19506 committed in release-4.0 by "Shyamsundar Ranganathan" <srangana@redhat.com> with a commit message- afr: capture the correct errno in post-op quorum check

If the post-op phase of txn did not meet quorm checks, use that errno to
unwind the FOP rather than blindly setting ENOTCONN.

Change-Id: I0cb0c8771ec75a45f9a25ad4cd8601103deddf0c
BUG: 1542382
Signed-off-by: Ravishankar N <ravishankar@redhat.com>
(cherry picked from commit 440a048f24b006c80af3d7bcd0a1f13fe3459d87)

Comment 3 Shyamsundar 2018-03-15 11:26:23 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-4.0.0, please open a new bug report.

glusterfs-4.0.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://lists.gluster.org/pipermail/announce/2018-March/000092.html
[2] https://www.gluster.org/pipermail/gluster-users/


Note You need to log in before you can comment on or make changes to this bug.