Bug 1542424 - Configuration fails on Error while evaluating a Function Call, Could not find data item compute_instanceha_short_node_names in any Hiera data file and no default supplied
Summary: Configuration fails on Error while evaluating a Function Call, Could not fin...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: puppet-tripleo
Version: 13.0 (Queens)
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: beta
: 13.0 (Queens)
Assignee: Michele Baldessari
QA Contact: Udi Shkalim
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-02-06 10:47 UTC by Marian Krcmarik
Modified: 2018-06-27 13:45 UTC (History)
6 users (show)

Fixed In Version: puppet-tripleo-8.3.0-0.20180222131528.3202394.el7ost
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-06-27 13:43:30 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Launchpad 1747643 None None None 2018-02-06 10:51:11 UTC
OpenStack gerrit 541240 None MERGED Do not fail fencing configuration when instanceha is disabled 2020-09-07 15:28:46 UTC
Red Hat Product Errata RHEA-2018:2086 None None None 2018-06-27 13:45:00 UTC

Description Marian Krcmarik 2018-02-06 10:47:03 UTC
Description of problem:
When configuring autofencing, It fails on following error:
"Error: Evaluation Error: Error while evaluating a Function Call, Could not find data item compute_instanceha_short_node_names in any Hiera data file and no default supplied at /etc/puppet/modules/tripleo/manifests/fencing.pp:61:13 on node controller-0.localdomain"

Version-Release number of selected component (if applicable):
puppet-tripleo-8.2.0-0.20180122224519.9fd3379.el7ost.noarch

How reproducible:
Always

Steps to Reproduce:
1. Start overcloud deploy to autoconfigure fencing by supplying fencing.yaml file

Actual results:
It fails on an error

Expected results:
Sucess

Additional info:

Comment 7 errata-xmlrpc 2018-06-27 13:43:30 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2018:2086


Note You need to log in before you can comment on or make changes to this bug.