Bugzilla will be upgraded to version 5.0. The upgrade date is tentatively scheduled for 2 December 2018, pending final testing and feedback.
Bug 1542669 - Service Catalog UI displays lowest platform version too early
Service Catalog UI displays lowest platform version too early
Status: CLOSED ERRATA
Product: OpenShift Container Platform
Classification: Red Hat
Component: Management Console (Show other bugs)
3.7.0
Unspecified Unspecified
medium Severity medium
: ---
: 3.9.0
Assigned To: Samuel Padgett
Yadan Pei
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2018-02-06 13:50 EST by Robert Bost
Modified: 2018-03-28 10:26 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Previously, the web console would not preselect the newest version of a builder image by default. It would also show the old version number of the first page of the wizard when adding a builder your project. This gave the wrong impression that your only choice was an old version of a language or framework. The web console now selects the newest version by default and doesn't show the version number in the wizard title since you can change versions in the next page.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2018-03-28 10:26:32 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2018:0489 None None None 2018-03-28 10:26 EDT

  None (edit)
Description Robert Bost 2018-02-06 13:50:27 EST
Description of problem:

In the Service Catalog web interface, when you click on a programming language, for example PHP, the first page of the wizard/guide shows the lowest version of the programming language. After clicking "Next" to see the next screen, you can then select a later version.

Version-Release number of selected component (if applicable): 3.7

Actual results: Lowest version of platform/runtime/language displayed in Service Catalog UI.


Expected results: I would not expect to see a version number displayed on the initial screen. I would also expect to see the highest version number to be selected by default in the version selection drop-down.
Comment 1 Samuel Padgett 2018-02-07 15:24:34 EST
Fix for sorting the options by newest first:

https://github.com/openshift/origin-web-console/pull/2781

Fix for not showing version in wizard title:

https://github.com/openshift/origin-web-catalog/pull/638

Related issue:

https://github.com/openshift/origin/issues/17552
Comment 2 Samuel Padgett 2018-02-12 16:25:00 EST
The catalog bump in this PR contains the fix:

https://github.com/openshift/origin-web-console/pull/2800
Comment 4 Yadan Pei 2018-02-22 01:28:55 EST
Now the initial wizard only shows image stream display name, version is not displayed. The description is shown in latest version in wizard and latest version is selected in the version selection drop-down

Move to VERIFIED
Comment 5 Yadan Pei 2018-02-22 01:29:25 EST
Verified on OpenShift Web Console: v3.9.0-0.47.0
Comment 8 errata-xmlrpc 2018-03-28 10:26:32 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:0489

Note You need to log in before you can comment on or make changes to this bug.