Bug 1542829 - Too many log messages about dictionary and options
Summary: Too many log messages about dictionary and options
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: core
Version: 4.1
Hardware: Unspecified
OS: Unspecified
urgent
urgent
Target Milestone: ---
Assignee: bugs@gluster.org
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-02-07 06:12 UTC by Amar Tumballi
Modified: 2018-06-20 17:59 UTC (History)
1 user (show)

Fixed In Version: glusterfs-v4.1.0
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-06-20 17:59:24 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Amar Tumballi 2018-02-07 06:12:15 UTC
Description of problem:

There are many logs added in the code base for developer's focus, but doesn't make sense in a release, as they are harmless for now.

Some examples of such logs are:

> [2018-02-04 17:28:13.213433] I [MSGID: 101097] [xlator.c:322:xlator_dynload_newway] 0-xlator: dlsym(xlator_api) on /usr\
/local/lib/glusterfs/4.1dev/xlator/storage/posix.so: undefined symbol: xlator_api. Fall back to old symbols

---- A user can't understand nor take any action to resolve it.

> [2018-02-04 17:28:13.209645] W [MSGID: 101002] [options.c:995:xl_opt_validate] 0-glusterfs: option 'address-family' is \
deprecated, preferred is 'transport.address-family', continuing with correction

---- This is set from glusterd itself during volgen, and a user can't resolve it.

> [2018-02-04 17:28:13.216827] I [dict.c:1126:data_to_uint16] (-->/usr/local/lib/glusterfs/4.1dev/rpc-transport/socket.so\
(socket_server_get_local_sockaddr+0x1c5) [0x7f11f138a865] -->/usr/local/lib/glusterfs/4.1dev/rpc-transport/socket.so(+0\
x12da0) [0x7f11f1389da0] -->/usr/local/lib/libglusterfs.so.0(data_to_uint16+0xf5) [0x7f11fe243b6c] ) 0-dict: key null, \
unsigned integer type asked, has string type [Invalid argument]

---- This is a warning about the code itself, and in a released version, user can't do anything about it.


> [2018-02-04 17:28:13.240042] W [MSGID: 101174] [graph.c:363:_log_if_unknown_option] 0-patchy-server: option 'rpc-auth.auth-null' is not recognized

---- Again, these options are set by glusterd, user can't do anything about it.

> [2018-02-04 17:28:14.532794] I [MSGID: 101016] [glusterfs3.h:738:dict_to_xdr] 0-dict: key 'trusted.ec.config' is would not be sent on wire in future [Invalid argument]

---- This is very much a warning for developer, but user can't handle nor resolve any of this.



Version-Release number of selected component (if applicable):
release-4.0 (On master branch these logs are still applicable)

How reproducible:
100%

Steps to Reproduce:
1. Run glusterfs process (glusterd; volume create; start; mount);

Actual results:
These logs are flooded in log files.

Expected results:

No logs which are not actionable, nor causing a behavior change in product should be logged in log file during normal operations.

Comment 1 Worker Ant 2018-02-07 06:17:42 UTC
REVIEW: https://review.gluster.org/19519 (core: move logs which are only developer relevant to DEBUG level) posted (#1) for review on release-4.0 by Amar Tumballi

Comment 2 Worker Ant 2018-02-09 15:36:01 UTC
COMMIT: https://review.gluster.org/19519 committed in release-4.0 by "Shyamsundar Ranganathan" <srangana@redhat.com> with a commit message- core: move logs which are only developer relevant to DEBUG level

Change-Id: I8b38e231b6160db8075f73773d4e7dc115a90d95
BUG: 1542829
Signed-off-by: Amar Tumballi <amarts@redhat.com>

Comment 3 Shyamsundar 2018-03-15 11:26:23 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-4.0.0, please open a new bug report.

glusterfs-4.0.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://lists.gluster.org/pipermail/announce/2018-March/000092.html
[2] https://www.gluster.org/pipermail/gluster-users/

Comment 4 Worker Ant 2018-05-08 18:31:18 UTC
REVIEW: https://review.gluster.org/19989 (core: move logs which are only developer relevant to DEBUG level) posted (#1) for review on release-4.1 by Amar Tumballi

Comment 5 Worker Ant 2018-05-09 17:42:19 UTC
COMMIT: https://review.gluster.org/19989 committed in release-4.1 by "Shyamsundar Ranganathan" <srangana@redhat.com> with a commit message- core: move logs which are only developer relevant to DEBUG level

Change-Id: I8b38e231b6160db8075f73773d4e7dc115a90d95
updates: bz#1542829
BUG: 1542829
Signed-off-by: Amar Tumballi <amarts@redhat.com>

Comment 6 Shyamsundar 2018-06-20 17:59:24 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-v4.1.0, please open a new bug report.

glusterfs-v4.1.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://lists.gluster.org/pipermail/announce/2018-June/000102.html
[2] https://www.gluster.org/pipermail/gluster-users/


Note You need to log in before you can comment on or make changes to this bug.