Bug 1542850 (CVE-2017-10689) - CVE-2017-10689 puppet: Unpacking of tarballs in tar/mini.rb can create files with insecure permissions
Summary: CVE-2017-10689 puppet: Unpacking of tarballs in tar/mini.rb can create files ...
Keywords:
Status: CLOSED WONTFIX
Alias: CVE-2017-10689
Product: Security Response
Classification: Other
Component: vulnerability
Version: unspecified
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Red Hat Product Security
QA Contact:
URL:
Whiteboard:
Depends On: 1542852 1543950 1543951
Blocks: 1542832
TreeView+ depends on / blocked
 
Reported: 2018-02-07 07:34 UTC by Sam Fowler
Modified: 2019-09-29 14:32 UTC (History)
28 users (show)

Fixed In Version: puppet 4.10.10, puppet 5.3.4
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-02-15 05:19:37 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHSA-2018:2927 None None None 2018-10-16 15:20:36 UTC

Description Sam Fowler 2018-02-07 07:34:50 UTC
In puppet before versions 4.10.10 and 5.3.4, when unpacking tarballs with minitar in lib/puppet/module_tool/tar/mini.rb, files are unpacked with the same permissions as in the tarball allowing for files with unsafe permissions.


Upstream Advisory:

https://puppet.com/security/cve/CVE-2017-10689


Upstream Issue:

https://tickets.puppetlabs.com/browse/PUP-7866


Upstream Commit:

https://github.com/puppetlabs/puppet/commit/17d9e02da3882e44c1876e2805cf9708481715ee

Comment 1 Sam Fowler 2018-02-07 07:35:17 UTC
Created puppet tracking bugs for this issue:

Affects: fedora-all [bug 1542852]

Comment 3 Kurt Seifried 2018-02-09 16:10:30 UTC
Please note that Puppet 3.x has mini.rb with the exact same code as 4.x, so it appears to be vulnerable, additionally the patch at https://github.com/puppetlabs/puppet/commit/17d9e02da3882e44c1876e2805cf9708481715ee should fix it.

Comment 6 Andrej Nemec 2018-05-14 13:56:15 UTC
Statement:

Red Hat Product Security has rated this issue as having security impact of Low. This issue affects the versions of puppet as shipped with:
* Red Hat Satellite 6.  A future update may address this issue. 
* Red Hat OpenStack Platform versions 6-12.  Although the affected code is present in shipped packages, the affected code can only be exploited by deploying unsupported custom puppet modules. This issue is not currently planned to be addressed in future updates. 

For additional information, refer to the Issue Severity Classification: https://access.redhat.com/security/updates/classification/.

Comment 7 errata-xmlrpc 2018-10-16 15:20:19 UTC
This issue has been addressed in the following products:

  Red Hat Satellite 6.4 for RHEL 7

Via RHSA-2018:2927 https://access.redhat.com/errata/RHSA-2018:2927


Note You need to log in before you can comment on or make changes to this bug.