Bug 154291 - kernel gets wedged when removing airo module while in use
kernel gets wedged when removing airo module while in use
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
4
All Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-04-08 22:22 EDT by Havoc Pennington
Modified: 2015-01-04 17:18 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-10-06 16:16:35 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Havoc Pennington 2005-04-08 22:22:18 EDT
This sounds like a "don't do that then" but it happens in real situations with
networkmanager

So the simple reproducer is:

 - bring up eth0 which is a wireless airo
 - "rmmod airo"
 - hangs with "unregister_netdevice: waiting for usage count to be 0"
 - all network-related processes are now locked up, so you can't 
   do anything to bring the usage count to 0
 - you can't kill any of the network-related processes
 - you have to reboot afaict

If you do the rmmod after an "ifdown eth0" then it works fine.

The reason this happens with NetworkManager is basically:
 - across suspend/resume the airo driver gets confused out of its mind
 - without NetworkManager you can work around this by "ifdown eth0; rmmod airo; 
   ifup eth0"
 - with NetworkManager you can't do the "ifdown" part of the workaround so it 
   would be convenient if "rmmod airo" worked with the interface still up, 
   or "rmmod airo; killall NetworkManager" worked

There are probably better fixes, like:
 - have the airo driver not get confused when you suspend
 - have NetworkManager bring down the interface on suspend

Anyway, something is hosed, feel free to bounce this buck around ;-)

Thanks
Comment 1 Dan Williams 2005-04-10 08:05:46 EDT
I fixed a bug last week which caused 1 file descriptor to get leaked every DHCP transaction on the 
device.  That might have been the problem.
Comment 2 Dan Williams 2005-04-10 08:08:08 EDT
Also note that if you send NM the "sleep" message, it will shut down all devices and essentially "ifdown" 
them.  If you send it "awake", it will re-enable them and find a new connection.  You have to add it to 
your suspend/resume scripts, because nothing in the system broadcasts shutdown/wake events or 
anything.
Comment 3 Dave Jones 2005-10-06 01:27:51 EDT
still a problem with latest errata ?
Comment 4 Dan Williams 2005-10-06 11:28:00 EDT
Most likely a firmware issue, should update to 5.60.08 or later.

Note You need to log in before you can comment on or make changes to this bug.