Bug 154292 - sound-juicer segfaults on extraction
sound-juicer segfaults on extraction
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: sound-juicer (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: John (J5) Palmieri
:
Depends On:
Blocks: FC4Blocker
  Show dependency treegraph
 
Reported: 2005-04-08 23:14 EDT by Bill Nottingham
Modified: 2014-03-16 22:53 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-05-18 15:03:25 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bill Nottingham 2005-04-08 23:14:32 EDT
Description of problem:

SSIA

Version-Release number of selected component (if applicable):

2.10.1-1

How reproducible:

Every time.

Steps to Reproduce:
1. Hit extract
2.
3. Profit!
  
Actual results:

Segfaults

Expected results:

Extracts

Additional info:

Program received signal SIGSEGV, Segmentation fault.
[Switching to Thread -1208138048 (LWP 11945)]
0x00d6e850 in gm_audio_profile_get_extension ()
   from /usr/lib/libgnome-media-profiles.so.0
(gdb) bt
#0  0x00d6e850 in gm_audio_profile_get_extension ()
   from /usr/lib/libgnome-media-profiles.so.0
#1  0x08056205 in pop_and_extract () at sj-extracting.c:121
#2  0x006a86f7 in g_cclosure_marshal_VOID__VOID ()
   from /usr/lib/libgobject-2.0.so.0
#3  0x0069d172 in g_closure_invoke () from /usr/lib/libgobject-2.0.so.0
#4  0x006ac9bb in g_signal_connect_closure_by_id ()
   from /usr/lib/libgobject-2.0.so.0
#5  0x006ae107 in g_signal_emit_valist () from /usr/lib/libgobject-2.0.so.0
#6  0x006ae47b in g_signal_emit () from /usr/lib/libgobject-2.0.so.0
#7  0x0093e9bc in gtk_button_clicked () from /usr/lib/libgtk-x11-2.0.so.0
#8  0x00940141 in gtk_button_get_alignment () from /usr/lib/libgtk-x11-2.0.so.0
#9  0x006a86f7 in g_cclosure_marshal_VOID__VOID ()
   from /usr/lib/libgobject-2.0.so.0
#10 0x0069cc86 in g_cclosure_new_swap () from /usr/lib/libgobject-2.0.so.0
#11 0x0069d172 in g_closure_invoke () from /usr/lib/libgobject-2.0.so.0
#12 0x006ac610 in g_signal_connect_closure_by_id ()
   from /usr/lib/libgobject-2.0.so.0
#13 0x006ae107 in g_signal_emit_valist () from /usr/lib/libgobject-2.0.so.0
#14 0x006ae47b in g_signal_emit () from /usr/lib/libgobject-2.0.so.0
#15 0x0093e938 in gtk_button_released () from /usr/lib/libgtk-x11-2.0.so.0
#16 0x0093f834 in gtk_button_set_relief () from /usr/lib/libgtk-x11-2.0.so.0
#17 0x009f7e72 in gtk_marshal_VOID__UINT_STRING ()
   from /usr/lib/libgtk-x11-2.0.so.0
#18 0x0069cc86 in g_cclosure_new_swap () from /usr/lib/libgobject-2.0.so.0
#19 0x0069d172 in g_closure_invoke () from /usr/lib/libgobject-2.0.so.0
#20 0x006acb47 in g_signal_connect_closure_by_id ()
   from /usr/lib/libgobject-2.0.so.0
#21 0x006ade7b in g_signal_emit_valist () from /usr/lib/libgobject-2.0.so.0
#22 0x006ae47b in g_signal_emit () from /usr/lib/libgobject-2.0.so.0
#23 0x00ad37e3 in gtk_widget_activate () from /usr/lib/libgtk-x11-2.0.so.0
#24 0x009f65d7 in gtk_propagate_event () from /usr/lib/libgtk-x11-2.0.so.0
#25 0x009f6a14 in gtk_main_do_event () from /usr/lib/libgtk-x11-2.0.so.0
#26 0x008a8ce4 in gdk_screen_get_setting () from /usr/lib/libgdk-x11-2.0.so.0
#27 0x0063846e in g_main_context_dispatch () from /usr/lib/libglib-2.0.so.0
#28 0x0063b476 in g_main_context_check () from /usr/lib/libglib-2.0.so.0
#29 0x0063b763 in g_main_loop_run () from /usr/lib/libglib-2.0.so.0
#30 0x009f5cd5 in gtk_main () from /usr/lib/libgtk-x11-2.0.so.0
#31 0x08050c06 in main (argc=80, argv=0x50) at sj-main.c:1088

If I open the prefs, the choice for output format is blank (and has no available
choices.) Perchance that has something to do with it.
Comment 1 Bill Nottingham 2005-04-08 23:15:59 EDT
Appears to be a dup of 150839, except it's most certianly not fixed with
2.10.1-1 for me.
Comment 2 John (J5) Palmieri 2005-04-09 01:47:38 EDT
> If I open the prefs, the choice for output format is blank (and has no available
> choices.) Perchance that has something to do with it.

That would do it.  Hmm perhaps your gstreamer or gstreamer-plugins install is
messed up.  Try running gst-register-0.8.
Comment 3 Bill Nottingham 2005-04-11 01:23:14 EDT
Didn't help.
Comment 4 John (J5) Palmieri 2005-04-12 13:36:39 EDT
hmm, ok, was this a fresh install or update?  Try running gst-register (not the
0.8 version).  That seemed to fix other problems for me.
Comment 5 John (J5) Palmieri 2005-04-12 13:40:41 EDT
hmm, interesting.  gst-register and gst-register-0.8 are the same (diff doesn't
show any differences) though running gst-register fixed some problems I was
having  where as gst-register-0.8 did not.

Ok, also can you post the output of

rpm -q gstreamer
rpm -q gstreamer-plugins
Comment 6 Bill Nottingham 2005-04-12 13:47:45 EDT
$ rpm -q gstreamer gstreamer-plugins
gstreamer-0.8.9-4
gstreamer-plugins-0.8.8-5

Running gst-register didn't help either.
Comment 7 Ray Strode [halfline] 2005-04-25 15:21:37 EDT
If you force reinstall gstreamer and gstreamer-plugins, does it

1) display any %post errors?
2) fix this bug?
Comment 8 Bill Nottingham 2005-04-25 15:29:46 EDT
No errors, doesn't fix it.
Comment 9 John (J5) Palmieri 2005-05-04 12:16:14 EDT
Can you try once again.  New gstreamer and gnome-media have been put in rawhide
that may fix this issue.  Upgrade to the new gnome-media and gstreamer first.
Comment 10 Ray Strode [halfline] 2005-05-04 14:17:20 EDT
Bill, are you still seeing this? How about with a fresh install?
Comment 11 Bill Nottingham 2005-05-04 14:33:58 EDT
Still happens with current gstreamer/gstreamer-plugins/gnome-media.

Doesn't happen on the fresh x86_64 install sitting next to me.
Comment 12 Ray Strode [halfline] 2005-05-11 16:43:42 EDT
So is this just an upgrade problem then?  
Comment 13 John (J5) Palmieri 2005-05-11 16:52:27 EDT
Yes, we figured out that one of the gconf keys wasn't being populated correctly
we just don't know why yet.
Comment 14 Ray Strode [halfline] 2005-05-18 15:03:25 EDT
We're going to close this since it seems like an isolated anomaly that is
probably related to upgrading from rawhide.   

John says you were able to manually fix it, yea?
Comment 15 Bill Nottingham 2005-05-18 15:10:25 EDT
Yes.

Note You need to log in before you can comment on or make changes to this bug.