Bug 1542920 - dnf download fails for certain repos
Summary: dnf download fails for certain repos
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: dnf   
(Show other bugs)
Version: rawhide
Hardware: s390x
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: Marek Blaha
QA Contact:
URL:
Whiteboard:
Keywords: Triaged
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-02-07 11:15 UTC by Jonathan Hermann
Modified: 2018-06-28 08:29 UTC (History)
9 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2018-06-28 08:24:56 UTC
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Jonathan Hermann 2018-02-07 11:15:41 UTC
Description of problem:

For some self-created repos, dnf fails in downloading packages. Package installation is possible, though.
When trying to download, the path is wrong - the last folder within the path simply is omitted by dnf. Failing with:

[Errno 2] No such file or directory

However, the package is available within the repo, and repodata has the correct path:

find /home/drvbld/mock/nightly-build/f27/autobuild -name smc-tools-1.0.99-20180205*
/home/drvbld/mock/nightly-build/f27/autobuild/20180205/smc-tools-1.0.99-20180205.0.5094441.2bf5b05.fc27.s390x.rpm

grep "smc-tools" 533bd8183ccea99aea1f26f043551dea9798e85010729b3a2f122fd311877207-primary.xml |grep 20180205
<location href="20180205/smc-tools-1.0.99-20180205.0.5094441.2bf5b05.fc27.s390x.rpm"/>




Version-Release number of selected component (if applicable):

Tried with the latest dnf version on F27, which is 2.7.5-2.fc27.
The oldest system I have around where I can verify the problem is a F25 with dnf 1.1.10-6.fc25.
The latest system I have where it's working is a F23 with dnf 1.1.10-1.fc23.



How reproducible:

On my systems, all the time.



Steps to Reproduce:

1. cat dnf.conf 
[nightly-build]
name=nightly-build
baseurl=file:///home/drvbld/mock/nightly-build/f27/autobuild

2. dnf -c dnf.conf download smc-tools-1.0.99-20180205.0.5094441.2bf5b05.fc27.s390x



Actual results:
[Errno 2] No such file or directory: '/home/drvbld/mock/nightly-build/f27/autobuild/smc-tools-1.0.99-20180205.0.5094441.2bf5b05.fc27.s390x.rpm'



Expected results:

Downloading the rpm package to the current location.

Comment 2 Jaroslav Mracek 2018-06-28 08:24:56 UTC
The issue is solved by dnf-3.0.1-1 that was released into rawhide.


Note You need to log in before you can comment on or make changes to this bug.