Note: This bug is displayed in read-only format because the product is no longer active in Red Hat Bugzilla.

Bug 1543082

Summary: Wrong CPU types provided for Intel's hosts.
Product: [oVirt] cockpit-ovirt Reporter: Nikolai Sednev <nsednev>
Component: Hosted EngineAssignee: Ryan Barry <rbarry>
Status: CLOSED DUPLICATE QA Contact: Pavel Stehlik <pstehlik>
Severity: urgent Docs Contact:
Priority: unspecified    
Version: 0.11.7CC: bugs, cshao, dguo, huzhao, nsednev, qiyuan, rbarry, sbonazzo, yaniwang, ycui, yisong, yzhao
Target Milestone: ---Flags: nsednev: planning_ack?
nsednev: devel_ack?
nsednev: testing_ack?
Target Release: ---   
Hardware: x86_64   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2018-02-08 12:14:16 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: UX RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Embargoed:
Attachments:
Description Flags
Screenshot from 2018-02-07 19-18-17.png none

Description Nikolai Sednev 2018-02-07 17:18:36 UTC
Created attachment 1392786 [details]
Screenshot from 2018-02-07 19-18-17.png

Description of problem:
Cockpit doesn't shows correct CPU type for Vintage deployment of SHE over Gluster.
For Intel host it provided AMD CPU types.

Deployment will fail as there is no Intel CPU type available in drop down menu.

Host's real CPU type:
[root@puma18 ~]# hostname
puma18.scl.lab.tlv.redhat.com
[root@puma18 ~]# rpm -qa | grep gdeploy
[root@puma18 ~]# lscpu
Architecture:          x86_64
CPU op-mode(s):        32-bit, 64-bit
Byte Order:            Little Endian
CPU(s):                12
On-line CPU(s) list:   0-11
Thread(s) per core:    2
Core(s) per socket:    6
Socket(s):             1
NUMA node(s):          1
Vendor ID:             GenuineIntel
CPU family:            6
Model:                 44
Model name:            Intel(R) Xeon(R) CPU           E5645  @ 2.40GHz
Stepping:              2
CPU MHz:               2400.000
CPU max MHz:           2400.0000
CPU min MHz:           1600.0000
BogoMIPS:              4800.60
Virtualization:        VT-x
L1d cache:             32K
L1i cache:             32K
L2 cache:              256K
L3 cache:              12288K
NUMA node0 CPU(s):     0-11
Flags:                 fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe syscall nx pdpe1gb rdtscp lm constant_tsc arch_perfmon pebs bts rep_good nopl xtopology nonstop_tsc aperfmperf pni pclmulqdq dtes64 monitor ds_cpl vmx smx est tm2 ssse3 cx16 xtpr pdcm pcid dca sse4_1 sse4_2 popcnt aes lahf_lm tpr_shadow vnmi flexpriority ept vpid dtherm arat
[root@puma18 ~]# 


Version-Release number of selected component (if applicable):
cockpit-ovirt-dashboard-0.11.11-0.1.el7ev.noarch
ovirt-hosted-engine-ha-2.2.4-1.el7ev.noarch
ovirt-hosted-engine-setup-2.2.9-1.el7ev.noarch
rhvm-appliance-4.2-20180202.0.el7.noarch
Linux 3.10.0-693.17.1.el7.x86_64 #1 SMP Sun Jan 14 10:36:03 EST 2018 x86_64 x86_64 x86_64 GNU/Linux

How reproducible:
100%

Steps to Reproduce:
1.On Intel CPU type host with RHEL7.4, using Cockpit, try to deploy Vintage SHE over Gluster.

Actual results:
AMD CPU type provided instead of Intel and deployment fails.

Expected results:
For intel CPU should be appropriate Intel CPU, for AMD-AMD.

Additional info:
Screenshot from deployment.

Comment 1 Ryan Barry 2018-02-07 18:00:16 UTC
Nikolai -

This strongly appears to be a duplicate of https://bugzilla.redhat.com/show_bug.cgi?id=1528818

Can you please check the output of:
virsh -r capabilities | grep -m 1 "<vendor>" 

If libvirt is down (or you see something other than <vendor>${vendor}</vendor>), it's a dupe.

Comment 2 Nikolai Sednev 2018-02-08 09:09:10 UTC
puma19 ~]# systemctl status libvirtd
● libvirtd.service - Virtualization daemon
   Loaded: loaded (/usr/lib/systemd/system/libvirtd.service; enabled; vendor preset: enabled)
  Drop-In: /etc/systemd/system/libvirtd.service.d
           └─unlimited-core.conf
   Active: inactive (dead)
     Docs: man:libvirtd(8)
           http://libvirt.org
puma19 ~]# virsh -r capabilities | grep -m 1 "<vendor>" 
error: failed to connect to the hypervisor
error: Failed to connect socket to '/var/run/libvirt/libvirt-sock-ro': No such file or directory

Looks like you're absolutely right.

Comment 3 Ryan Barry 2018-02-08 12:14:16 UTC

*** This bug has been marked as a duplicate of bug 1528818 ***