Bug 1543120 (CVE-2018-6871) - CVE-2018-6871 libreoffice: Remote arbitrary file disclosure vulnerability via WEBSERVICE formula
Summary: CVE-2018-6871 libreoffice: Remote arbitrary file disclosure vulnerability via...
Keywords:
Status: CLOSED ERRATA
Alias: CVE-2018-6871
Product: Security Response
Classification: Other
Component: vulnerability
Version: unspecified
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Red Hat Product Security
QA Contact:
URL:
Whiteboard:
Depends On: 1545023 1545024 1545033 1545034 1545035 1545036
Blocks: 1543123
TreeView+ depends on / blocked
 
Reported: 2018-02-07 18:45 UTC by Pedro Sampaio
Modified: 2021-02-17 00:50 UTC (History)
6 users (show)

Fixed In Version: libreoffice 5.4.5, libreoffice 6.0.1
Doc Type: If docs needed, set a value
Doc Text:
A flaw was found in libreoffice before 5.4.5 and before 6.0.1. Arbitrary remote file disclosure may be achieved by the use of the WEBSERVICE formula in a specially crafted ODS file.
Clone Of:
Environment:
Last Closed: 2018-03-14 09:32:44 UTC


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHSA-2018:0418 0 normal SHIPPED_LIVE Moderate: libreoffice security update 2018-03-07 02:46:23 UTC
Red Hat Product Errata RHSA-2018:0517 0 normal SHIPPED_LIVE Moderate: libreoffice security update 2018-03-13 22:37:39 UTC

Description Pedro Sampaio 2018-02-07 18:45:10 UTC
A flaw was found in libreoffice. Arbitrary remote file disclosure may be achieved by the use of the WEBSERVICE formula in a specially crafted ODS file.

Comment 2 Doran Moppert 2018-02-14 05:07:31 UTC
Created libreoffice tracking bugs for this issue:

Affects: fedora-all [bug 1545023]

Comment 4 Doran Moppert 2018-02-14 05:14:39 UTC
Note that libreoffice upstream refers to this as CVE-2018-1055, while MITRE calls it CVE-2018-6871.  Both identifiers refer to the same issue.

Comment 8 errata-xmlrpc 2018-03-06 21:43:25 UTC
This issue has been addressed in the following products:

  Red Hat Enterprise Linux 7

Via RHSA-2018:0418 https://access.redhat.com/errata/RHSA-2018:0418

Comment 9 errata-xmlrpc 2018-03-13 18:26:51 UTC
This issue has been addressed in the following products:

  Red Hat Enterprise Linux 6

Via RHSA-2018:0517 https://access.redhat.com/errata/RHSA-2018:0517


Note You need to log in before you can comment on or make changes to this bug.