Bug 154317 - Uncomprehensible message in authconfig
Summary: Uncomprehensible message in authconfig
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: authconfig   
(Show other bugs)
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Tomas Mraz
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords: i18n, StringChange
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-04-09 19:20 UTC by Christian Rose
Modified: 2007-11-30 22:11 UTC (History)
1 user (show)

Fixed In Version: authconfig-5.0.2-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-10-14 15:09:06 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Christian Rose 2005-04-09 19:20:36 UTC
#: authconfig.c:492 authconfig-gtk.py:355
#, c-format, python-format
msgid ""
"To properly connect to a LDAP server using TLS you need to copy the PEM form "
"CA certificate which signed your server's certificate to the '%s' "
"directory.\n"
"Then press OK."

This message is almost totally incomprehensible to me, and as a consequence not
translateable.
This message was unclear even to a sysadmin friend who knows about certificates.
He has never ever heard of "PEM forms", but rather "PEM format".

Comment 1 Tomas Mraz 2005-04-10 21:04:56 UTC
PEM form is of course synonym for PEM format. I've just done Google for "PEM
form" and it returned about 183 hits from which many have exactly this meaning.

Form as you surely know is not only something to be filled in but also a synonym
for shape or - format.

I agree that the whole sentence is a little bit complicated and surely it could
be better formulated as I am not a native english speaker. Feel free to suggest
a better formulation but try to not make it much longer.

It should mean:
If you want to use the TLS protocol for securing the LDAP connection to the LDAP
server you need to copy the certificate of the CA (certificate authority) which
signed your server's certificate to the '%s' directory. The CA certificate must
be in the PEM form / format.


Comment 2 Göran Uddeborg 2005-04-13 20:16:46 UTC
Since I was "invited" :-) I'll try to give a suggestion.  I do not explain any
of the acronyms; that would make it longer.  Hopefully, they are in a context
where the user can be expected to understand at least most of them?  I split it
up in several sentences, which in my opinion makes it easier to read.  I also
try to put each acronym as an obvious description of the following noun.  That
ought to simplify for anyone who doesn't know all of them.  It is not quite
obvious in a description like "the ABC form DEF certificate".  (And while I
understand "form", "format" is certainly more common, and more clear if you do
not know what PEM is.)

But I'm not native English speaker either.  So take this for what it is, another
suggestion.

To connect with the TLS protocal to an LDAP server, you need a CA certificate. 
It should have signed you server's certificate, and it should be in PEM format.
 Copy it to the directory `%s'.
Press OK when ready.

Comment 3 Tomas Mraz 2005-09-08 14:14:29 UTC
OK, I will reword the message similarly to your proposal.



Note You need to log in before you can comment on or make changes to this bug.